Update to new DriveWorks Beta

I am trying to update the Drive PX2 to the new DriveWorks beta because I need to use some TensorRT 4 features.

But when I try to use sdkmanager I got a connection error. So I try to follow the procedure: update AURIX to the new version (4.02.04.00) then try sdkmanager again.

I followed the steps found at https://docs.nvidia.com/drive/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23wwconnect_header

I copied the following files to Tegra A /lib/firmware:

DRIVE-V5.0.10-P2379-EB-Aurix-With3LSS-4.02.04.elf
DRIVE-V5.0.10-P2379-EB-Aurix-With3LSS-4.02.04.hex
DRIVE-V5.0.10-P2379-EB-Aurix-With3LSS-4.02.04.map
DRIVE-V5.0.10-P2379-NV-Aurix-UPDATE-3.01.01.hex

Then I run “sudo /bin/bash /etc/systemd/scripts/nv_aurix_check_fw.sh -auto_update”

The system booted and I run the command again (as documentation recommended). The second time I got the error:

starting Aurix FW checking…
Checking arguments…
Rootfs EB FW version is 4.02.04.0
Response From Aurix
Flashing EB FW
Syncing File System done
New fw Filename : DRIVE-V5.0.10-P2379-EB-Aurix-With3LSS-4.02.04.04.elf
New EB fw version 4.02.04.00
flash_new_fw malloc error for curr_list_buf->buf

Am I doing something wrong?

Dear tiago.cajahyba,

Please see below bold comments.
Run the command above for a third time to update UPDATE firmware. nv_aurix_update always checks first for the EB firmware to be the latest. Once EB firmware is updated to the latest, it checks for UPDATE firmware version and updates if it is required.

If the above problem is not solved, please try to update aurix fw with Upgrading the Firmware on Windows in https://docs.nvidia.com/drive/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23wwconnect_header

Steve,

I followed the windows instructions and now I have Aurix Firmware updated! Thank you!

But now, after I run the sdkmanager Beta 0.9.8.2002 again, when it tries to flash Tegra A+B I got an Error. I tried using PRG mode and RUN mode.


flash_2379_parallel.log (99 KB)
SdkManagerTerminal.log (26.5 KB)

See log file

Duplicate message. So I removed the content.

Dear tiago.cajahyba,

The flashing should be done with RUN mode, not PRG mode.
The errors are from bootburn.sh and I suspect that there might be other target setup errors before flashing.
Could you upload the full logs available at below locations?
~/.nvsdkm/sdkm.log
~/.nvsdkm/logs

SteveNV,

Files Attached.
logs.zip (51.4 KB)
sdkm.log (2.6 MB)

Dear tiago.cajahyba,

Thank you for your update. We will check the log and update.