Updated jetson tx1 using software updater and now mouse and keyboard don't work

I somehow updated the jetson to ubuntu 16.04 however I didn’t research how to do it before, so I did it using the software updater program. I now don’t know why my keyboard and mouse won’t work. So then I put it in usb recovery mode thinking that might work and now nothing shows up on my screen when I turn it on. I really just won’t to reset it back to the factory state. I don’t understand the other posts I have seen on the topic so please help.

By “software updater”, do you mean JetPack? Or the command line flash.sh script?

Generally speaking recovery mode temporarily turns the Jetson into a custom USB device which the driver package knows how to flash, but the recovery mode itself has no effect on the Jetson unless the flash program runs. JetPack is a front end to flash.sh and also additional package management utilities.

If you used JetPack, was it version 3.1? If you used flash.sh, did you also install the sample rootfs and run apply_binaries.sh?

When I was updating I used a program that looks like this in ubuntu: http://imgur.com/a/G2ZAl
I ran through the program until it completed with installing ubuntu 16.04. When I rebooted the system, Neither my keyboard nor mouse worked. I’m not sure whether it is in recovery mode or not anymore, however it doesn’t display anything on my monitor. Thank you for responding so quickly.

Recovery mode goes away if you cycle power or hit the reset button. Recovery mode only occurs if you hold down the recovery button while bringing up power or resetting power. In and of itself recovery mode makes no permanent change to a Jetson.

So was this update the built in update Ubuntu offers and not one you downloaded to your desktop PC? If so, this essentially destroys all of the files which NVIDIA provides for customization since Ubuntu has no concept of this hardware. You should only update via flash.sh+driver package or JetPack. The Ubuntu mechanism for migrating breaks the install. See this for the recommended version (the current version) of L4T:
https://developer.nvidia.com/embedded/linux-tegra

Here is a listing of prior versions:
https://developer.nvidia.com/embedded/linux-tegra-archive
https://developer.nvidia.com/embedded/jetpack-archive

The good news is that no harm has occurred, just flash again, but instead use the desktop PC Linux while the Jetson is in recovery mode and the micro-B USB cable is attached between host and Jetson. You only need the ethernet cable attached if using JetPack, and even then you only need this for installing extra packages (flash does not use the ethernet).

Note on the R28.1 L4T page that there are driver packages listed for TX1 and TX2. If you use command line with flash.sh and driver package be sure you get the TX1 driver package (everything else is the same between TX1 and TX2 downloads starting with R28.1).

I have a question you link: https://developer.nvidia.com/embedded/linux-tegra, in the instructions it mentions the release package, and I was wondering if that meant the driver package. BTW I did use the built in update Ubuntu offers

In some locations you will see an abbreviated shorthand notation such as this:

<L4T_RELEASE_PACKAGE>

This is essentially a distinct identifier for a version combined with the hardware the version supports. The place this is usually applied is indeed the “driver package”, though you may also see it used wherever there is a mention of a combination of hardware architecture and supporting software. Example is the driver package which supports the TX1 and TX2:

TX1: Tegra210_Linux_R28.1.0_aarch64
TX2: Tegra186_Linux_R28.1.0_aarch64

…or the sample rootfs for both TX1 and TX2:

Tegra_Linux_Sample-Root-Filesystem_R28.1.0_aarch64

…both TX1 and TX2 are aarch64 architecture, both driver package and sample rootfs are L4T R28.1. Two different driver packages and a single shared sample rootfs.

The document uses for one example for a TX2:

<L4T_RELEASE_PACKAGE> is Tegra186_Linux_R28.1_aarch64.tbz2 for the Jetson TX2 release package filename.

Substitute “Tegra186” for TX2 and “Tegra210” for TX1 (a TK1 is “Tegra124”).

So all of that is just to be able to write instructions in the documents once when it applies to more than one type of Jetson using a slightly different file name in need of unpacking. For all things TX1 look for the “Tegra210” in the name.