Updating Cuda driver version

Dear All,

I am running CUDA on WSL2 with ubuntu. I install cuda driver following the intruction given here. CUDA on WSL :: CUDA Toolkit Documentation
I was running GROMACS program on GPU. Graphcs card I have Geforse2060. Everything was ok. But recently driver got updated. Now GROMACS can not recognise it. I tried to rebuild the gromacs but no success. Here is the .nvidia-smi.exe output-
Fri Jul 9 17:29:30 2021
| NVIDIA-SMI 462.31 Driver Version: 462.31 CUDA Version: 11.2 |
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 GeForce RTX 2060 WDDM | 00000000:01:00.0 Off | N/A |
| N/A 39C P8 11W / N/A | 164MiB / 6144MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| No running processes found |

However the gromacs unable to find it.

Command line:
gmx pdb2gmx --version

GROMACS version: 2021.2
Verified release checksum is d91a739522d82c53dc47c2276b9ac5fae3b2119283e84e3a1c7bed8ce741fda2
Precision: mixed
Memory model: 64 bit
MPI library: thread_mpi
OpenMP support: enabled (GMX_OPENMP_MAX_THREADS = 64)
GPU support: CUDA
SIMD instructions: AVX2_256
FFT library: fftw-3.3.8-sse2-avx
RDTSCP usage: enabled
TNG support: enabled
Hwloc support: disabled
Tracing support: disabled
C compiler: /usr/bin/gcc GNU 9.3.0
C compiler flags: -mavx2 -mfma -Wno-missing-field-initializers -fexcess-precision=fast -funroll-all-loops -O3 -DNDEBUG
C++ compiler: /usr/bin/c++ GNU 9.3.0
C++ compiler flags: -mavx2 -mfma -Wno-missing-field-initializers -fexcess-precision=fast -funroll-all-loops -fopenmp -O3 -DNDEBUG
CUDA compiler: /usr/local/cuda/bin/nvcc nvcc: NVIDIA (R) Cuda compiler driver;Copyright (c) 2005-2020 NVIDIA Corporation;Built on Wed_Jul_22_19:09:09_PDT_2020;Cuda compilation tools, release 11.0, V11.0.221;Build cuda_11.0_bu.TC445_37.28845127_0
CUDA compiler flags:-std=c++17;-gencode;arch=compute_35,code=sm_35;-gencode;arch=compute_37,code=sm_37;-gencode;arch=compute_50,code=sm_50;-gencode;arch=compute_52,code=sm_52;-gencode;arch=compute_60,code=sm_60;-gencode;arch=compute_61,code=sm_61;-gencode;arch=compute_70,code=sm_70;-gencode;arch=compute_75,code=sm_75;-gencode;arch=compute_80,code=sm_80;-Wno-deprecated-gpu-targets;-gencode;arch=compute_35,code=compute_35;-gencode;arch=compute_53,code=compute_53;-gencode;arch=compute_80,code=compute_80;-use_fast_math;-D_FORCE_INLINES;-mavx2 -mfma -Wno-missing-field-initializers -fexcess-precision=fast -funroll-all-loops -fopenmp -O3 -DNDEBUG
CUDA driver: 0.0
CUDA runtime: N/A

As you see in the last line. May I know how to fix it?

Thank you

Best Regards


What Windows build are you running? (winver.exe)
What’s your WSL2 kernel version? (uname -a)

Also you need to install latest windows driver 470.76 for WSL2 from CUDA on WSL | NVIDIA Developer


Thanks for your reply. The windows build is 22000.65

Driver version 462.31.

Best Regards

since you are using Windows 11 you can install the latest official driver 471.11 that includes WSL support.
NVIDIA DRIVERS GeForce Game Ready Driver WHQL

I updated driver and its working fine now. Thank you for your help. Have a nice day.

Best Regards


1 Like