Updating DriveOS 5.2 from drive software

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Trying to upgrade from drive software 10.0 to DRIVE OS 5.2 using SDK Manager. But i’m facing problems when installing CUDA X on host.
Eventhough i uninstalled DRIVE SW10, Im unable to install DRIVE OS 5.2. Im attaching the error logs.

Preparing to unpack …/libnvinfer-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb …
Unpacking libnvinfer-dev-cross-aarch64 (6.3.1-1+cuda10.2) …
dpkg: error processing archive /var/nv-tensorrt-repo-cuda10.2-trt6.3.1.3-d5l-cross-ga-20200724/./libnvinfer-dev-cross-aarch64_6.3.1-1+cuda10.2_all.deb (–unpack):
trying to overwrite ‘/usr/lib/aarch64-linux-gnu/stubs/libnvinfer.so’, which is also in package libnvinfer5-cross-aarch64 5.1.4-1+cuda10.2
Errors were encountered while processing:

Hi @vimal.prasath ,

Could you try again after issuing below command?

sudo dpkg -P libnvinfer5-cross-aarch64

If it still doesn’t help, please provide the complete logs (~/.nvsdm/ on you host system). Thanks.

1 Like

Thanks @VickNV ,
We were able to flash the DRIVE OS 5.2 to AGX Pegasus. Now we are trying to get the device USB Port number and serial ID, we tried navigating to etc/minicom directory and we dont find any minirc files. Attaching the nvsdm logs as well .Please let me know how to solve this issue. The kernel version we are using is 5.4.0-66-generic. SDKM_logs_DRIVE_OS_5.2.0_SDK_Linux_for_DRIVE_AGX_Developer_Kit_2021-02-26_11-58-49.zip (157.5 KB)

We have seen some threads to see if we can connect to aurix. we tried tegrareset command over the ttyUSB3 port, we were able to see tegra A reboot over ttyUSB2. but we not getting any response from ttyUSB6 and we are not sure how to log in and enable ssh.
We are following drive AGX system setup and not sure how to proceed with enabling SSH and enabling display and GUI.

Just want to double confirm that DRIVE OS 5.2.0 installation is successful and the current issue is that you cannot access Xavier B from UART, right?

Please check AGX Xavier is not responding to see if it helps on your issue. Thanks.

Thanks @VickNV
We were able to access the Xavier B over minicom and enabled ssh and display as well

Hi @vimal.prasath , did you mean the issue was fixed?