Updating Intelrealsense Camera Firmware with Jetson Xavier

I have a question regarding the Jetson Xavier, we are testing it with an IntelRealSense D415 Camera.
We are having trouble to Install package that belong to intel called “intel-realsense-dfu” in order to update the camera firmware.
When I tried to find the problem I found that ARM CPUs do to not support this package on a 4.9 Tegra Kernel and we were unable to update the camera firmware .
When I installed the Xavier I followed the Nvidia recommended installation .
The OS and kernel version that we are running is - Ubuntu 18.04.2 LTS (GNU/Linux 4.9.108-tegra aarch64) .
I would like to ask if you have any advice to solve this issue or any recommendation.

I tried to follow the instructions posted by JetsonHacks community, and it still doesn’t work for me.
Does the JetsonHack solution even supported by Nvidia?
Is there any other way to install the intel-realsense-dfu package?

Hi ayehud, can you try the updated firmware from this post? Thanks.

https://devtalk.nvidia.com/default/topic/1048804/jetson-agx-xavier/realsense-camera-unstable/post/5364499/#5364499

Hi dusty_nv,
I did update the Xavier firmware with the link you sent me here, but thats not the issue here,
The issue is regarding updating the camera firmware with the Jetson Xavier and not updating the Xavier itself (which is what you sent me here),
and in order to update the IntelRealSense D415 camera i need to install a package called intel-realsense-dfu

Regards,
Ariel Y.

That package is supplied and supported by Intel. You should post on the Intel forums to ask whether it’s available for the NVIDIA Jetson AGX Xavier device. NVIDIA can do nothing about that package.

My guess is you need to use an Intel CPU to update the firmware of the camera. I e, install Linux on a x86 machine, install the intel package, plug in the camera, and update the firmware from there. That will work, and will solve your problem, so that’s the easiest solution.