Updating packages on Jetson TX2 via JetPack 3.0

Hi,

I’m new to linux & Jetson so sorry in advance if my questions don’t belong here or are trivial.
My ultimate goal is to run TensorFlow on the TX2.

  1. How can I see what packages are installed on the TX2?
    I’ve marked all packages during the first installation via JetPack 3.0 but I see that I don’t have e.g CUDNN on the TX2. And I’m not sure that CUDA SDK 8.0 is actually installed…

  2. How can I run JetPack and use it to add/update packages on the TX2?

Any help is highly appreciated!
Matan

Hi Matan, if you haven’t re-flashed your TX2 with JetPack since receiving it, it is recommend to updated the outdated factory image and BSP. Download JetPack to your x86_64 host PC (running Ubuntu) and connect the TX2 to your PC over micro-USB and ethernet. Alternatively, you can just connect over ethernet and have JetPack install cuDNN and CUDA Toolkit on top of your existing install.

JetPack also downloads the deb packages in a subdirectory under where it is located on the host machine, after it downloads them you could manually copy them to your TX2 and install them. You can also find guides to Tensorflow here on the wiki: http://elinux.org/Jetson_TX2#Deep_Learning

Thanks very much dusty!

I was able to build TensorFlow 1.0.1 following Jetsonhacks’ tutorial.
I use python 2.7 and have some code that requires several modules such as scipy and matplotlib.

I tried to install these modules following https://scipy.org/install.html
“pip install --user scipy matplotlib”, but the installation failed.
Looks like the modules depend on other modules that are not installed, e.g. mkl_rt.

Can you please suggest how to deploy these modules on the Jetson TX2?
Is there a slim installation that is hardware-specific for the Jetson?

Many thanks!
Matan

Hi,

Please try this:

sudo apt-get install python-scipy

Thanks @AstaLLL,
That helped :)