Updating/Upgrading the Jetson Nano OS causing problems with Intel Wifi Card and Resolution

I’ve been having issues with this since I got it over a year ago, but I’ve had a project come up that could use it, so I’ve been trying to finally fix it.

The OS run’s fine when the image is first flashed and put into the board, but after updating, 2 prominent issues come up.

  1. The screen resolution loads at about 1/4 the normal resolution, then after a minute and a half, it goes black, and returns in full resolution.

  2. The Intel 8625 is not detected at all by the nano after updating and upgrading the components. I’ve tried to fix it via drivers from intel, but it didn’t fix anything. I can see the wireless connection option before updating and upgrading, but once I do that, it vanishes along with the NIC in any way to check connected hardware. My assumption, based on old linux forum threads, is that it may be an issue with the kernel, but I don’t know how I could troubleshoot or fix it.


What was your method to “update” your board?

Just running ‘sudo apt update’ and ‘sudo apt upgrade’ once the initial ubuntu setup is finished.

What was your first revision of jetpack release on the board? I mean before the system update.

It was running the latest jetpack from a sd card flashed earlier - Jetpack 4.4


Ok. I see.

For problem 1 (resolution): please attach the full desmg

For problem 2 (intel 8265): please also share the result of sudo rfkill -list

I’ve attached the desmg for the first problem dmesg.txt (66.8 KB)

However, ‘sudo rfkill -list’ returned nothing when I ran it. I did run nmcli, lspci, and lshw (network), and have attached them to a second message (3 file limit) for any extra information that may help with the problem.

Here are the other 3 text files, in case they are helpful

nmcli.txt (343 Bytes) lspci.txt (351 Bytes) lshw.txt (1.9 KB)


There is i2c error showing up on your dmesg and cause the EDID read failure.

That is why the monitor fails to work. It is more like a hardware issue. Would you mind reflashing your board?

Yes. Would you like any more logs on a fresh installation? Or should I just refrain from updating through the terminal.

Please check if issue is still even after you re-flash your board.

If so, then maybe you need to RMA this jetson Nano and get a new one.

This time, I flashed the sd card, and turned it on to the same resolution problem. It did not have the resolution problem before updating when I reflashed the os this morning. I also could not see the intel wireless card, as I could this morning after my initial reflash.

dmesg(1).txt (71.3 KB)

Probably hardware defect. Please file RMA request.

Could you point me in the direction for that. Thank you for the help!


Please check this page.