Updating VPI library on Jetpack 4.4.1 to support features in Jetpack 4.6

I’m interested in whether it’s possible to update just the VPI library between Jetpack 4.4.1 and 4.6?

sudo apt-get update
sudo apt-get install libnvvpi1

Hi,

The CUDA version is different. (4.6: 10.2.460 vs. 4.4.1: 10.2.89)
So it’s possible to meet the ‘insufficient driver error’ due to compatibility.
Since you need to run a lib built with 10.2.460 on the environment setup for 10.2.89.

A better way is to upgrade your BSP with OTA feature also.
You can do this via the instructions shared in the below document:
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html#wwpID0E0AL0HA

Thanks.