Upgrade the image for Jetson Nano from 32.3.1 to 32.6.1

Currently, I have the image for flashing into any device Jetson Nano with version L4T 32.3.1. But I’d like to upgrade this image upto L4T version 32.6.1. Is there any way to do that?
I tried to use this image and L4T 32.6.1 folder to flash manually. (sudo ./flash.sh -r jetson-nano-emmc mmcblk0p1).
But after flashing device, I accessed my device and checked version of device with command (head -1 /etc/nv_tegra_release).
That showed: # R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019.
I need some help or any solutions.


It is either flash process does not succeed at all or you boot from something else.

Could you please explain for me in detail?
I flashed with my image of L4T v32.3.1 and copy it into L4T v32.6.1 folder. And then I used the command.
“sudo ./flash.sh -r jetson-nano-emmc mmcblk0p1”. The result of process responsed Successfully.
So I accessed device and checked version. It isn’t 32.6.1.
You can help me to solve it, right? Or Any way to upgrade my image that created from L4T v32.3.1 upto v32.6.1 ?


Does your so-called “I flashed with my image of L4T v32.3.1 and copy it into L4T v32.6.1 folder” mean you copy your system.img to 32.6.1 folder?

Yes. I copy system.img into L4T v32.6.1 folder

Then I guess your system is partially updated to 32.6.1 but parts of them are still 32.3.1…

Actually we have a official OTA method here.


But I am not sure if it can still work after your operation.

I tried it. It worked. But how is the way that I can get the image of L4T version 32.6.1?
Because I have to use this image to flash for multiple device.

Just do the same thing as what you’ve done in rel-32.3.1.

You mean: I have to create the L4T v32.6.1 folder and some configuration file (Ex: rootfs/…) of device without any information of the old image (I mean: 32.3.1). And create image file with command (sudo ./flash.sh -r -k APP -G /home/user/Desktop/backup.img jetson-nano-emmc mmcblk0p1)


Ok. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.