Upgrade to L35.4

After pressing ‘Enter’:

Warning: Not all of the space available to /dev/nvme0n1 appears to be used, you can fix the GPT to use all of the
space (an extra 6 blocks) or continue with the current setting? 
Fix/Ignore? Fix                                                           
Fix
Partition number? 1                                                       
1
Partition name?  [APP]?                                                   

Warning: Cannot get compatible board name.
3767-000-0000--1--p3509-a02+p3767-0000-
.
.
.

and finally, after all of that:

dpkg: dependency problems prevent configuration of nvidia-l4t-kernel-headers:
 nvidia-l4t-kernel-headers depends on nvidia-l4t-kernel (= 5.10.120-tegra-35.4.1-20230801124926); however:
  Package nvidia-l4t-kernel is not configured yet.

dpkg: error processing package nvidia-l4t-kernel-headers (--configure):
 dependency problems - leaving unconfigured
Setting up nvidia-cuda-dev (5.1.2-b104) ...
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of nvidia-l4t-jetson-io:
 nvidia-l4t-jetson-io depends on nvidia-l4t-kernel (>> 5.10.120-tegra-35.4-0); however:
  Package nvidia-l4t-kernel is not configured yet.
 nvidia-l4t-jetson-io depends on nvidia-l4t-kernel (<< 5.10.120-tegra-35.5-0); however:
  Package nvidia-l4t-kernel is not configured yet.

dpkg: error processing package nvidia-l4t-jetson-io (--configure):
 dependency problems - leaving unconfigured
Setting up nvidia-l4t-x11 (35.4.1-20230801124926) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up samba-libs:arm64 (2:4.15.13+dfsg-0ubuntu0.20.04.4) ...
Setting up libpoppler97:arm64 (0.86.1-0ubuntu1.3) ...
Setting up ghostscript (9.50~dfsg-5ubuntu4.9) ...
Setting up software-properties-common (0.99.9.12) ...
Setting up nvidia-l4t-3d-core (35.4.1-20230801124926) ...
Setting up libnvvpi2 (2.3.9) ...
pva_allow and/or /etc/pva/allow.d missing! Falling back to force-overwrite of system allowlist
Setting up libtiff-dev:arm64 (4.1.0+git191117-2ubuntu0.20.04.9) ...
dpkg: dependency problems prevent configuration of nvidia-l4t-display-kernel:
 nvidia-l4t-display-kernel depends on nvidia-l4t-kernel (= 5.10.120-tegra-35.4.1-20230801124926); however:
  Package nvidia-l4t-kernel is not configured yet.

dpkg: error processing package nvidia-l4t-display-kernel (--configure):
 dependency problems - leaving unconfigured
Setting up nvidia-l4t-initrd (No apport report written because MaxReports is reached already
35.4.1-20230801124926) ...
Setting up vpi2-demos (2.3.9) ...
Setting up nvidia-l4t-multimedia (35.4.1-20230801124926) ...
dpkg: dependency problems prevent configuration of nvidia-l4t-kernel-dtbs:
 nvidia-l4t-kernel-dtbs depends on nvidia-l4t-kernel (= 5.10.120-tegra-35.4.1-20230801124926); however:
  Package nvidia-l4t-kernel is not configured yet.

dpkg: error processing package nvidia-l4t-kernel-dtbs (--configure):
 dependency problems - leaving unconfigured
Setting up No apport report written because MaxReports is reached already
libsmbclient:arm64 (2:4.15.13+dfsg-0ubuntu0.20.04.4) ...
Setting up nvidia-l4t-pva (35.4.1-20230801124926) ...
Setting up poppler-utils (0.86.1-0ubuntu1.3) ...
Setting up python3.9-vpi2 (2.3.9) ...
Setting up libpoppler-cpp0v5:arm64 (0.86.1-0ubuntu1.3) ...
Setting up nvidia-l4t-gbm (35.4.1-20230801124926) ...
Setting up libpoppler-glib8:arm64 (0.86.1-0ubuntu1.3) ...
Setting up nvidia-l4t-vulkan-sc-samples (35.4.1-20230801124926) ...
Setting up vpi2-dev (2.3.9) ...
Setting up nvidia-l4t-camera (35.4.1-20230801124926) ...
Setting up software-properties-gtk (0.99.9.12) ...
Setting up nvidia-l4t-gstreamer (35.4.1-20230801124926) ...
Setting up nvidia-l4t-weston (35.4.1-20230801124926) ...
Setting up ghostscript-x (9.50~dfsg-5ubuntu4.9) ...
Setting up nvidia-l4t-graphics-demos (35.4.1-20230801124926) ...
Setting up nvidia-l4t-jetson-multimedia-api (35.4.1-20230801124926) ...
Setting up python3.8-vpi2 (2.3.9) ...
Setting up vpi2-samples (2.3.9) ...
Setting up nvidia-vpi (5.1.2-b104) ...
Setting up nvidia-jetpack-runtime (5.1.2-b104) ...
Setting up nvidia-vpi-dev (5.1.2-b104) ...
Setting up nvidia-jetpack-dev (5.1.2-b104) ...
Setting up nvidia-jetpack (5.1.2-b104) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:arm64 (2.64.6-1~ubuntu20.04.6) ...
Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.3) ...
Errors were encountered while processing:
 nvidia-l4t-kernel
 nvidia-l4t-kernel-headers
 nvidia-l4t-jetson-io
 nvidia-l4t-display-kernel
 nvidia-l4t-kernel-dtbs
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish

I attempt to just rerun dist-upgrade again with similar errors.