Upgrading CMake on Jetson AGX

I’ve been having some trouble upgrading my CMake from the version that comes with the AGX/18.04 (CMake 3.10). I am trying to install OpenPose and they recommend CMake 3.12>=. So, I downloaded the tar.gz of the latest CMake release, CMake 3.19.1, and tried to run the following commands after un-tar.

In the cmake folder:
sudo ./configure
sudo make -j8

make ends with an error seen in the photo I attached.

“undefined reference to pthread_atfork”

I checked and I do have pthread installed.
Does anyone know what could be wrong and how I can get this to work?

Sorry for the poor quality phone photo, I don’t have access to the AGX right now!

Tomorrow I can update with more info, thought I’d post tonight anyways…thanks for the help!

I can confirm that cmake 3.16.4 can be built and run on Xavier AGX with JetPack 32.4.4. (I don’t remember the details on the build process, though.)

Issue solved. Here is an overview of what seems to have worked for me…

Trying to manually install from source any newer version of CMake did not end up working for me. I found out that on the software store(?) for L4T (I am running version 32.4.3 by the way) there were two available versions of CMake.

First, there was version 3.10, the one that ships with the AGX and secondly there was a download for version 3.19.1. I was able to successfully download and install the newer version from the software store and things seem to be working now. I was able to install OpenPose successfully with cmake-gui (v 3.19.1).

So, the problem with linking pthread_atfork during manual installation of cmake was not solved, however, going about it this way allowed me to upgrade my cmake.

2 Likes