Upgrading to JetPack 5.0.2, Linux for Tegra 35.1

I am using Jetson Xavier NX with Ubuntu 18.04 LTS, Jet Pack 4.6, Linux for Tegra 32.6.1
with AverMedia EN715 carrier board

Could you suggest easiest way to upgrade to JetPack 5.0.2, Linux for Tegra 35.1 ?

  • Ubuntu 18.04 from developer_download_nvidia_com has arm64 but it supports only JetPack 4.6
  • Ubuntu 20.04 from developer_download_nvidia_com does not have arm64
  • Carrier board AverMedia EN715 BSP does not support JetPack 5.0.2
  • JetPack 5.0.2 .deb package is available at repo_download_nvidia_com, but this repository does not have Release and Package files required by a standard ubuntu/debian (apt) repository

This is an issue, you need to have their BSP to get device upgrade to JetPack 5.0.2.

Thanks @kayaccc. I will check with carrier board vendors. But is it possible to install jetpack, l4t, cuda, etc through apt-get? There seems to be support for arm64 (sbsa) but not for jetson. The Release and Package files are missing in the repositories. Could you elaborate on this part ?

hello saurabh.daptardar1,

you may access apt server to have post installation.
for example, $ sudo apt install nvidia-l4t-jetson-multimedia-api
please see-also Update Packages for Jetson Devices for packages.
thanks