[urgent]Problem that it is not applied even if time zone is changed in GUI Date and time

So the issue has been resolved, as it seems to me? Right?

1 Like

The part which should not change would be the contents of file “/etc/timezone”. Is that part resolved?

1 Like

Hello,

No,
If you set the time using timedatectl like this, the time is set. However, if you change the time zone through the gui, the time of the changed time zone does not appear.

My purpose is to display the time in the format of the changed time zone even through the date command when changing the time zone through gui.

Thank you.

Hello,

no.
As @WaneWWW told me
If you set the time using timedatectl, you can set the time (in the photo above, you can change it to “2020-10-21 09:47:27”, which is Seoul time, and check it through the date command. But the above answer As shown in the picture attached to, if you change the LA time zone through the gui, the time of the changed time zone does not appear.

My purpose is to display the time in the format of the changed time zone even through the date command when changing the time zone through gui.

Thank you.

@neuezeal
it seems that you are looking to avoid use of the GUI interface which works, so that you could use command line terminal somehow
is it the meaning of the your latter message?

1 Like

How did you get the time zone called “Ameriac/Los_Angeles”? I am not aware of such a spelling for “America”.

1 Like

Hello,

You want to use the GUI interface.

Reorganizing the current problem
The customer changed the time zone through the GUI interface (Time & Date), but it did not change.
Isn’t that a problem? It started with the question.

The end goal is to change the time zone using the GUI interface.

Thank you.

Hello,

cat /etc/timezone

Thank you.

Has someone modified or created their own zone information files on this system rather than using the standard files from the zoneinfo database? If so, the actual time zone offsets specified within the file may not necessarily match the expected behavior.

@WayneWWW, @Andrey1984

Hello,

image
After setting it manually, you can also check that the time and time zone you check through the date do not match.


image
If you use the echo $TZ command to check the time zone, it comes out differently.

Thank you.

Hello,


I checked with journalctl -f
As shown in red, the timezone setting is not possible due to the authority.

How do I solve this problem?

Thank you.

Hello,

I checked with journalctl -f
In nano, where the timezone is normally changed, the timezone setting is fine as follows.

Thank you.

As I understand, changing the time zone in either the GUI or using “timedatectl set-timezone” will update the following files:

  • /etc/timezone - The contents of this text file will simply be set to the relative path and name of the zoneinfo file under the /usr/share/zoneinfo/ directory (i.e. America/Los_Angeles).
  • /etc/localtime - The contents of this binary file will either be copied from the corresponding zoneinfo file or it will be recreated as a symbolic link to the named zoneinfo file.

I do not believe that the user’s TZ environment variable setting will be modified, it wouldn’t be dynamically updated in already running processes anyway. However, if the TZ environment variable has been set to a particular time zone for a user (and any running processes), that will override the system’s time zone for programs such as “date” (see https://www.gnu.org/software/libc/manual/html_node/TZ-Variable.html for more information).

Running “unset TZ” followed by the “date” command should show the “system configured” local time in that instance of the shell.
Alternatively, running “export TZ=:/etc/localtime” followed by “date” should also show the “system configured” local time, again only for that instance of the shell.

1 Like

You have to be root to change the “/etc” content. Some settings are just for display for a specific account, and are not system-wide. Use sudo for commands which change the system settings, don’t use sudo for commands which just display a different timezone customization for an individual account.

1 Like

@neuezealdoes does the issue persist if the jetson is reflashed?
I understand that if permissions were changed at some point using root user; some user specific folders could have got the permissions changed, so that they could be only accessed from the root user. Make sure all permissions are proper for user settings ,for root settings etc.
There are profiles of users that probably could contain differnt settings for each user [ just a guess]. Also there should be a default profile.

Hello,

This is a situation where you cannot refresh.
Nano is in the customer
We are supporting it remotely.

Is it because the current default account doesn’t have permission related to time & date?

But the strange thing is that all flashing in the same way and creating an account, the problem only occurs in this Nano.

Thank you.

@neuezeal you may set up locally an error like that probably
e.g at local jetson change permission for the /home folder to root/ root
or change permissions only to the certain files [e.g. files related to user local settings including date & timezone] , as a result the user won’t be able to access certain user’s files unless the permissions will allow doing that which will require manually correct the permissions
Once you are able to repeat the error locally and resolve it you should be able to sort it out on the remote jetson

1 Like

@neuezeal
try this gui invoked explicitly with sudo
does it work for you?

sudo dpkg-reconfigure tzdata
1 Like

I can see Configuring tzdata

so go ahead and try configuring it via the text gUI

1 Like