*URGENT* Wrong deepstream-test version runs from Azure

Hi,

I’ve updated my deepstream-test5-app, complied it, them copy it to /opt/nvidia/deepstream/deepstream-4.0/bin.

However when I run the application via Azure, the original application executes (not the updated one). I’m running the application as per the below article:

Is there anything wrong I’m doing?

Hi,

Could you double check if you are using the modified binary/library?
Thanks.

The modified binary has the same name deepstream-test5-app, I just replaced the file in /opt/nvidia/deepstream/deepstream-4.0/bin folder. But when I run from Azure, the original binary is being called, I also tried to rename the binary, but then I’m getting that the file doesn’t exists

Is there an update on my query?

Hi,

I’m waiting for a response for my ticket 8 hours.

Regards,

Abood

I’ve managed to push the new binary to docker and it runs fine, by adding the below bind:

“Binds”: [
“/opt/nvidia/deepstream/deepstream-4.0/bin/:/usr/bin/”
]
}

However I’ve 2 more queries:

  1. I’ve modified gst-dsexample pluglin “libnvdsgst_dsexample.so”, but I’m unable to figure out the target bind in docker, the file located in /opt/nvidia/deepstream/deepstream-4.0/lib/gst-plugins, so where should I push it in docker?
  2. I want to install OpenALPR in docker, please let me know if I need to install it in different image and container? or I should I install it in my image below?
    marketplace.azurecr.io/nvidia/deepstream-iot2-l4t

Could you please support urgently, as I can’t wait until Monday to solve this issue.

Hi,

It looks like the modification is on the host so the docker cannot access it.
Enable binding is one possible way or you can apply the changed directly on the docker.

1. Path is /opt/nvidia/deepstream/deepstream-[ver]/lib/gst-plugins
2. YES. Please use the image to have the deepstream support.

Thanks.