USB 3.0 and WiFi for TX1 on Auvidea J100-IMU carrier

I’ve been using a pretty standard setup on my TX1, doing visual odometry with a Stereolabs ZED camera and SLAM on a Jetson TX1 and radar, all working fine on the OEM dev board. Unfortunately once I use the Auvidea J100-IMU board for mounting on my hexacopter, I lose USB 3.0 capability and I am not able to access the IMU the carrier includes. I think there is a required kernel recompile and and dtb modification, could anyone give me a hand with that?
I’ve seen various “firmware” files on the auvidea support site but with the latest version I am losing WiFi and USB 3.0 is still not working, and I haven’t had much luck with their support ticket system.

I had the same issue, with both J120 and J140, and once I flashed the nvidia Tx1 the USB3 worked but no Wifi.
If you read the’s firmware support page, the wifi part is missing in their driver package.

To install the auvidea driver package you need to reflash the Tx1 and then you loose everything on the tx1, so ensure to do a backup out of Tx1 of your files before you start. I usually back my stuff to the cloud to be safe before I do anything drastic on my tx1 and tx2.

So I havent got the wifi to work unfortunately, but USB3 works fine (using a 4k camera and 1920x1080 digital fpv camera).

also you can see which rate your USB device has using this command on the Tx1:

# lsusb -t

usb3 is 5000M
usb2 is 480M

If you follow the kernel messages, USB3 is “super speed”, and USB2 is “high speed”

# sudo dmesg --follow


# sudo dmesg --follow | grep usb

I’ve just seen an update to the images they’ve uploaded (v2.2) that mentions a WiFi fix, I’ll be trying that later.

Hav you had any luck? I just ordered a J100 (it’s in the mail), but now I’m seeing nothing but problems from other people on these forums, and zero support from Auvidea. Wondering if I’ve made a bad decision…