USB 3.0 camera get the 'select timeout' error

Hi every one,
I’m using an USB 3.0 camera on Nvidia Jetson Nano board

This is the device information when I use the v4l2-ctl to check

v4l2-ctl --info --list-devices

3.0 USB Camera (usb-70090000.xusb-1.4):
	/dev/video0

Driver Info (not using libv4l2):
	Driver name   : uvcvideo
	Card type     : 3.0 USB Camera
	Bus info      : usb-70090000.xusb-1.4
	Driver version: 4.9.140
	Capabilities  : 0x84200001
		Video Capture
		Streaming
		Extended Pix Format
		Device Capabilities
	Device Caps   : 0x04200001
		Video Capture
		Streaming
		Extended Pix Format

I use this code to test the camera with Opencv

import cv2
import time

cap = cv2.VideoCapture(0)

if not cap.isOpened():
    raise IOError("Cannot open webcam")
    cap.release()
    cv2.destroyAllWindows()

cap.set(cv2.CAP_PROP_FRAME_WIDTH,1920);
cap.set(cv2.CAP_PROP_FRAME_HEIGHT,1080);

for i in range(100):
	start = time.time()
	ret, frame = cap.read() 
	stop = time.time() - start
	print('Exe time', stop)
	
	cv2.imshow('large size', frame) 
	c = cv2.waitKey(1)
	if c == 27:
		break
	
cap.release()
cv2.destroyAllWindows()

The code works with USB 2.0 camera.
But it returns the ‘select timeout’ error with USB 3.0 camera above.
I tried the same code and camera on Ubuntu 16 installed on my desktop PC, it works without any error?
I guest some problem with the driver on Nvidia Jetson Nano.

Do you have any suggestion to fix the problem?

Thank you.

Hi,
Your issue is purely about OpenCV. Suggest you go to https://answers.opencv.org/questions/
You may also try gstreamer or tegra_multimedia_api to launch USB cameras.

I don’t believe this issue is actually “purely OpenCV”. I had the same problem, it turns out it’s very likely a USB bandwidth issue. Try using a PCIe to USB 3 adapter, this fixed it for me.

I’m using the TX2 and this one works for me: https://www.amazon.com/dp/B009L86CHC/ref=cm_sw_r_cp_awdb_t1_cMLTDb9XWX349