USB 3.0 SSD cannot be detected

Dear Community,

I have a Micro 600 SSD drive (Crucial BX500 - SSD - 1 TB - SATA 6Gb/s - CT1000BX500SSD1 - Solid State Drives - connected via SATA-to-USB 3.0 and USB 3.0 to Jetson Nano (Jetson Nano lives within a custom designed PCB board). We notice a strange behavior when the SSD USB 3.0 is connected first and then power up Jetson, the USB 3.0 cannot be detected.

We then made a serial connection to the Jetson and monitor the logs, we found out we have to wait till Linux Kernel has started first, and then plug in the USB 3.0 like a hot plug, then it can be detected.

We tried the same procedure on another system (another PCB board) and don’t see this behavior. We tried to swap two Jetson modules between two systems but the behavior remains the same.

I have attached two log files here, one for the “Good system / PCB board” where hot plug is NOT needed at all, the other one for the “Bad system / PCB board” where hot-plug is needed after kernel has started.

Can someone please take a look at these logs files and maybe there’s indications that the USB probing has failed when kernel started? thank you!



full_log_on_bad_unit_have_to_plug_in_ssh_after_kernel_is_up.txt (38.8 KB)
full_log_on_good_unit.txt (23.4 KB)

jetson nano uart log by default does not have kernel log… please remove quiet in extlinux.conf to dump full log.

Also, please try to reprodcue issue on NV devkit. If it cannot reprodcue, please review your hardware design.

Hi Wayne,

Thanks for your suggestion, we tried swap two Jetson modules on the two custom made PCB boards, the behavior remained the same, good is still good, bad is still bad, which makes us believe it’s something related to the custom PCB board. But certainly we can try the same procedure on Jetson SOM Dev Kit.

We did save the kernel log using dmesg after made the UART connection, you can find two log files here for comparison. It did spit out a few errors but it seemed from a google search most of these are harm-less errors. Can you please take a look at the kernel logs and let us know if you see anything that is suspicious? Is there a message in the kernel that will tell us the USB init failed? thank you.

You will see Mircon 600 SSD connected in the end of the bad unit kernel log, that’s because we unplugged the SSD and hot-plugged it back.



dmesg_log_after_unplug_reconnect_SSD_bad_unit.txt (73.2 KB)
dmesg_log_when_first_time_boot_up_bad_unit.txt (55.9 KB)
dmesg_log_when_first_time_boot_up_on_a_good_unit.txt (57.2 KB)

If you think this is related to custom PCB, then I don’t have any comment. Try to compare you own hardware design.
I don’t know you or your board. The dmesg does not help but only tells "yeah, there is indeed such issue’.

can you tell us which line in the kernel log that indicates the USB init failed? That could help us on troubleshooting, thanks!

There is no such line. No “usb init” fail.

It is just the SSD does not get detected. Feel like it does not exist.

The other usb seems still working. For example, looks like mouse is still there.

ok then, we didn’t seem find a line either warning us something is wrong with usb init. Yeah it’s bizarre, all other USB 2.0 ports are fine, they got detected, only this USB 3.0 port is not detected… thanks for the tips though!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.