USB cable(ACM0) port removal from Tx2 EVK getting AT command

Hi,whenever i am removing usb cable from TX2 EVK device and again inserting it on login console of USB i am getting AT commands automatically.

we have to remove these in our custom board

ANy help will be appreciated?

An AT command sounds to me like a modem program is running. If you are using a program such as minicom, then it may be programmed to send AT commands should it think you are talking to a modem. Can you give an example of the AT command, and what program are you using which shows this (it could be the program you are using for access doing this and not the Jetson itself)?

yes i am using minicom for baord console through ACM port…these commands are coming randomly on login console i am removing and then inserting usb cable on my laptop…this is coming without modem also???
does this behaviour belongs to tx2

Minicom was invented in the days of telephone modems. The AT commands were triggered to run once a carrier was detected, and those provided login information to the ISP. You should disable running those commands when used only as a serial terminal. It looks like it is minicom configuration doing this, not the Jetson, and minicom probably needs configuration changes.

You might verify by using a different serial console program. I like gtkterm. If your port is “/dev/ttyACM0”, then after you install gtkterm ("sudo apt-get install gtkterm"):
gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyACM0
(you will need to use “sudo” if you are not a member of group “dialout”)

There are also some other serial console programs, but the point is to verify that it is minicom itself which is sending those commands. I have not seen a dialup modem in a very very long time, so I don’t remember what it is to change to tell minicom to just act as a terminal and not to run the modem init.

Note: If this also occurs with gtkterm, then save a log of the session to post here.