USB Device not Responding when Separating D and Vcc Ground

Hi. I’m trying to fix some problems with the Jetson Nano low voltage.
When I attached a USB device camera, it warned about a low voltage.

To fix it, I tried separating D+ and D- pins from VCC and GND so that my Jetson Nano would not supply my camera. Here’s the diagram.

The problem is that when I tried connecting to the device and running the dmesg --follow, here’s what’s showing.

It’s supposed to work or am I missing something here. Thanks

Oh, sorry. But I got it now. So between the VCC GND and the battery, there exists a voltage regulator.
I thought it was considered common ground since it’s already connected to the battery but it’s not. So you need to create a common ground between the Jetson Nano and the Voltage Regulator.
Somehow, establishing a common ground is important for the flow of the current or stuff. Not really good at explaining it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.