USB not detected in Force Recovery mode

I was getting errors that I couldn’t resolve on my TX1 (Ubuntu 16.04 LTS) so I tried to re-flash the OS with force recovery and Jetpack. However, my host (intel nuc, Ubuntu 16.04 LTS, x86_64) computer is unable to detect the TX1 via USB when connected via the micro-USB port to the host.

host@host:~$ lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 8087:0a2a Intel Corp. 
Bus 002 Device 010: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 002 Device 009: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 002 Device 006: ID 04f2:0939 Chicony Electronics Co., Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I suspected it may be because all ports are USB3.0 capable so I tried the same procedure with a computer that has 2.0 ports but got the same results.

Normally a USB3 port on the host is not an issue, the port just throttles back to USB2 if the cable is not USB3 (there are other issues under a VM where this tends to fail sometimes). Just make sure the cable really is a micro-B cable and not an OTG cable used with some other device…if you used the supplied cable it will be micro-B. Be sure to hold the recovery button down solid while powering up or tapping the reset button. If that fails there may be other issues.

For reference, lsusb shows these devices
TK1 via “lsusb -d 0955:7140”
TX1 via “lsusb -d 0955:7721”
TX2 via “lsusb -d 0955:7c18”

Bingo. I used the supplied micro-B cable and the host computer saw the TX1 right away. Thanks.

Hey i am using a Virtual Machine, but even my Windows PC is unable to recognize the Jetson in Recover ymode. Its fine if the jetson is running normally and my PC detects a L4T device but as soon as i go into force recovery the device name changes to APX and im not able to recognize the jetson and hence i cant use the SDKmanager as i cant find the Jetson when using “lsusb” on the host virtual machine. Can you help me or tell me how i could best flash the Jetson from my position.

VMs usually fail to pass through USB correctly. This is compounded by flash itself resulting in multiple disconnects and reconnects…the VM tends to fail to pick the USB back up during a reconnect even if the USB originally worked. Officially, VMs are not supported, but many people do get this to work after finding the correct customization steps to force that USB device to be given to the VM no matter how often it disconnects and reconnects.