USB pen Drive

Hello everyone

I am using jetson Tk1 board.

I am trying to use my pen drive but the board can’t recognise it.


It’s not easy to help you with so few details.
I would suggest :
Before connecting your drive, in a shell run the command dmesg and note the numbers at the beginning of last line.
Then connect your drive and wait for 10 seconds. Then rerun dmesg again and scroll up to the line you’ve noted. This way, you can look to what has happened when you inserted it.
Expected behaviour should be to have the device recognized and installed, then finding partitions on it and mounting known file systems.
Post these lines here if it is not clear to you.

hi Honey,

ya I got those new lines:

[24072.607172] usb 2-1: Product: Mass Storage
[24072.607176] usb 2-1: Manufacturer: Generic
[24072.607180] usb 2-1: SerialNumber: 43196F8D
[24072.608438] usb-storage 2-1:1.0: USB Mass Storage device detected
[24072.609101] scsi2 : usb-storage 2-1:1.0
[24073.614357] scsi 2:0:0:0: Direct-Access Generic Flash Disk 8.07 PQ: 0 ANSI: 4
[24073.616417] sd 2:0:0:0: Attached scsi generic sg0 type 0
[24073.617878] sd 2:0:0:0: [sda] 15730688 512-byte logical blocks: (8.05 GB/7.50 GiB)
[24073.619194] sd 2:0:0:0: [sda] Write Protect is off
[24073.619219] sd 2:0:0:0: [sda] Mode Sense: 23 00 00 00
[24073.620359] sd 2:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[24073.654015] sda: sda1
[24073.658976] sd 2:0:0:0: [sda] Attached SCSI removable disk


The good news are your drive is working and correctedly detected, accessible as /dev/sda.
It has 1 partition : /dev/sda1.

It seems this partition is not automatically mounted. Possible causes are:

  • It is an unknown partition type for your system. Is your drive formatted ? If yes, which filesystem (FAT32, NTFS, …) ? If you don’t know, run the command:
sudo fdisk -l /dev/sda
  • You don’t have automount. In such case, you can try to mount manually. The exact syntax depends on the filesystem, I may help if you send the fdisk output.

Hi Honey,

I run those two below commands and it work properly with me:

sudo mkdir /media/usb
sudo mount /dev/sdb1 /media/usb