USB Ports gets locked

Hello,

When we unplugged the ssd from drive, it lock all the USB ports.

There is a small chance to bring the USB back when we reload the USB driver, otherwise we need to restart the system.

how to enable 8 cores, nvpmodel -m 0 not working, current can only use 6 cores.

Dear dhruvildarji1409,

-. USB
Does the symptom happen all USB port or a specific USB port?

-. CPU cores, please refer to below link and comments.

https://devtalk.nvidia.com/default/topic/1055220/general/tegrastats-reports-only-6-cpu-cores-/

This is expected; the Hypervisor setup for 5.0.13.2/DRIVE Software 8.0 was 8.0 shared cores across all the VMs, where 5.1.0.2/DRIVE Software 9.0 and later have 6 dedicated cores for the guest OS, and the remaining two shared for the non-guest VMs. This is to give more predictable performance to the guest VM by eliminating any interference from the Foundation Service VMs.

This doesn’t seem to be well documented anywhere unfortunately; best picture from the docs to explain against is below.

https://docs.nvidia.com/drive/active/5.1.0.2L/nvvib_docs/index.html#page/DRIVE%20Linux%20HYP%20PDK%20Development%20Guide%2FArchitecture%2Farchi_foundation.html%23

https://docs.nvidia.com/drive/active/5.1.0.2L/nvvib_docs/index.html#page/DRIVE%20Linux%20HYP%20PDK%20Development%20Guide%2FUtilities%2FAppendixTegraStats.html%23

Running tegrastats

When you run tegrastats on Linux devices, it prints statistics to stdout.

Example Log Print
RAM 2669/7846MB (lfb 1065x4MB) CPU [100%@345,100%@2419,100%@2419,100%@344,11%@346,100%@345] EMC_FREQ 17%@1600 GR3D_FREQ 0%@114 APE 150 MTS fg 0% bg 0% PLL@43C thermal@42.8C MCPU@43C Tboard@40C AO@42.5C GPU@49C PMIC@100C BCPU@43C Tdiode@43.5C VDD_IN 5224/3423 VDD_CPU 844/712 VDD_GPU 360/361 VDD_SOC 884/664 VDD_WIFI -114/-91 VDD_DDR 240/240
Attachments

-. nvpmodel tool.
The tool is for Jetson platform not Automotive platform. Thanks.

Hey Steve,

Yes it happens top all the USB ports for XA (Xavier A).

Thanks

Dear dhruvildarji1409,

Could you help to check on hostPC if DriveAGX USB ports are available or not using lsusb command like below? Thanks.

$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 043: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 003 Device 042: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 003 Device 041: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 003 Device 040: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 003 Device 039: ID 0424:2807 Standard Microsystems Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hey SteveNV,

I did lsusb on host pc. I get the following output. I can see one port 8087:0a2b Intel Corp.

$lsusb
Bus 009 Device 034: ID 0403:6011 Future Technology Devices International, Ltd FT 4232H Quad HS USB-UART/FIFO IC
Bus 009 Device 033: ID 0403:6011 Future Technology Devices International, Ltd FT 4232H Quad HS USB-UART/FIFO IC
Bus 009 Device 032: ID 0403:6011 Future Technology Devices International, Ltd FT 4232H Quad HS USB-UART/FIFO IC
Bus 009 Device 031: ID 0403:6011 Future Technology Devices International, Ltd FT 4232H Quad HS USB-UART/FIFO IC
Bus 009 Device 030: ID 0424:2807 Standard Microsystems Corp.
Bus 009 Device 024: ID 04f2:0833 Chicony Electronics Co., Ltd
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0a2b Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Dear dhruvildarji1409,

Thank you for you update.

One more thing, could you please help check below step and upload log info on this topic? Thanks.

  1. Run “sudo minicom -D /dev/ttyUSB2” on HostPC for XavierA
  2. Plug in a USB device to DriveAGX USB port
  3. Check log HostPC minicom terminal
  4. Unplug a USB device from DriveAGX
  5. Check log HostPC minicom terminal

Hi dhruvildarji1409,

Could you follow our last comments to provide the log if this USB problem still an issue to support?

Thanks