USB Powersupply starts after checking for camera

I have a Jetson Nano and want to use it with an Arducam Cammarray with four imx219 sensors. Now my problem is, that the Camarray needs an external powersupply via USB (as far, as I know, its also possible via GPIOs, but I don’t know, if that works with Jetson Nano too). Because I only have a 5V (it’s sometimes a bit higher or lower, because when booting, the JN needs more power) source, that is delivered by a battery, I can’t just use another plug. So I want to power it with one of the USB-connectors of the JN, but then I just get an error:
with "gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080,format=(string)NV12, framerate=(fraction)29/1’ ! nvoverlaysink
" I get:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:740 No cameras available
Got EOS from element "pipeline0".
Execution ended after 0:00:00.001296989
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

When I run it via OpenCV in Python (thats, how I want to use it), I just get a message, that there’s no camera detected to.
I think, that the problem is, that the Cammarray gets power, after the JN booted, because with external powersupply it works, when I give the Cammarray power before the JN.
Is there a way to check again, if a camera is connected, or a different solution?
Best regards, Konrad

hello KonradC,

I’m a little confused.

did you meant…
you use the USB port on carrier board as power-supply to this external camera board, and… you’re using a battery to provide power to Nano platform?

thank you for the fast reply. Yes I mean that. I think, that the USB port gives the Camera board power, after it checked, if any cameras are attached, because I can’t explain it different.
Best regards, Konrad

hello KonradC,

that’s no an ideal connections. it looks like an issue of camera device registration.

there’ll be sensor probing process during kernel initialization, it basically power-on/off camera devices for sanity check then register video node to linux sysnode. you should check USB port kept outputting 5V to this external camera board.
or, you may have a quick try for using a steady power-supply to narrow down the issue.

Yes I already tried it with an external USB-source, and it works with it. The Jetson Nano gives it power too, but only after it started, so it could already have checked, if any cameras are connected, or the cameras boot to slow. I’ll try to get it working with the gpios. I’ll write, if kt works.
Best regards, Konrad

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.