USB still cannot work after modify device-tree

Hi,

After I update Jetpack4.3, I found the USB cannot work. Then I search the developer forums and found some topic about this issue.

https://devtalk.nvidia.com/default/topic/1057885/jetson-tx2/usb-not-working-in-jetson-tx2-r32-2/post/5364464/#5364464
https://devtalk.nvidia.com/default/topic/1049988/jetson-tx2/third-usb-on-custom-board-not-working-with-jetpack-4-2/post/5330117/#5330117

I follow the topic to modify my device-tree and flash into my carrier board. But the usb3.0(type-A) cannot work. Only the OTG(microUSB) can work in device mode. My customer carrier board’s usb lane mapping is same as official carrier board. I have no idea now. Could you kindly help me solve this problem ?

Regards.

The board support package of your third party carrier board would be required, but sometimes people apply the BSP intended for a different JetPack/SDK Manager release. Was the manufacturer’s BSP intended for JetPack 4.3?

Hi linuxdev,
I am the manufacturer of this carrier board. I’m developing the BSP of Jetpack 4.3 now

Hi,
My customer board has no GPIO Expanders Chip(TCA9539 0x77 and TCA9539 0x74). Is it related to this?

Hi,

Better sharing your dmesg/dts to review the power-tree.

customer.loggz (68.2 KB)
tegra186-quill-p3310-1000-a00-00-base.dts.loggz (9.8 KB)
dmesg.loggz (57.0 KB)
Hi WayneWWW,
Here’s my uart boot log and dts. Dts’s line 137 to 143 and line 157 to 221 is my modification about usb

[    3.342454] tegra-xusb-padctl 3520000.xusb_padctl: no port found for USB2 lane 2
[    3.342473] tegra-xusb 3530000.xhci: USB2 port 0 has OTG_CAP
[    3.343842] tegra-xusb-padctl 3520000.xusb_padctl: no port found for USB2 lane 2
[    3.343848] phy phy-usb2.2: phy init failed --> -19
[    3.344522] tegra-xusb 3530000.xhci: failed to enable PHYs: -19

According to your log, you put usb2-2 in your pads but there is no usb2-2 in your ports.

dmesg1.loggz (55.2 KB)
like this ?


It cannot work. I upload my dmesg log.

Hi,

It is working. The old error log is gone and we have a new one now.
I would suggest you to read the document and check the kernel log to see which port get failure when probing.

Kernel driver you need to check ->
kernel/kernel-4.9/drivers/phy/tegra/xusb.c -> tegra_xusb_setup_ports

Hi,
Did you read my comment?

Hi, Thanks, I will check the code

Hi,WayneWWW
Thanks for your help. I add this then solve this problem.
usb2-2 {
status = “okay”;
mode = “host”;
vbus-supply = <&battery_reg>;
};

1 Like