USB to UART devices (RPLiDAR A1, Adafruit FT232H) not recognized by Xavier

Hello, I am quite new to Xavier, and I’m having some trouble setting up RPLiDAR A1 on my Xavier.

The problem looks like the device cannot be recognized when I plug it into the USB typeC port (the one above the power cable). I followed some instructions on , but I can’t find any relevant devices using “usb-devices” or “lsusb” command. In some threads , people solved the problem by installing USB to serial Kernel models for CP210x device (which is used by RPLiDAR), but I don’t think it’s necessary any more because it have been included in L4T28.2 or later. I appreciate any help regarding the issue.

Below are some information:

lsusb gives the following lines, with the LiDAR unplugged or plugged

Bus 002 Device 002: ID 05e3:0616 Genesys Logic, Inc. hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 05a3:9230 ARC International
Bus 001 Device 005: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 007: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg gives the following lines when I plug in the LiDAR

[ 2224.818893] ucsi_ccg 1-0008: port1 evt: Type-C Port Connect Detected
[ 2224.820794] ucsi_ccg 1-0008: [typec-port1] Cable state:1, cable id:2
[ 2232.661872] ucsi_ccg 1-0008: port1 evt: Source Disabled State Entered

This is my version info.

NVIDIA Jetson AGX Xavier
L4T 32.1.0 [ JetPack 4.2 ]
Board: t186ref
Ubuntu 18.04.2 LTS
Kernel Version: 4.9.140-tegra
CUDA 10.0.166

https://devtalk.nvidia.com/default/topic/1045343/jetson-agx-xavier/jetson-xavier-sensor-connection-tutorials/post/5304288/#5304288
https://www.jetsonhacks.com/2018/02/09/install-usb-serial-converter-kernel-modules-l4t-28-1/

The issue has been solved.

@tianqi.xu
How did you solve the issue?