USB Webcam on Nvidia Jetson TK1

Good day everyone,

I am attempting to interface a generic 1080p USB camera (link: click here) with an Nvidia Jetson TK1 board. After testing various techniques, the method that yielded the most success was using the gstreamer library. The necessary commands, scripts, and instructions used were presented by Jetson hacks

The problem that I am having is that only the first frame of the video feed is being displayed on the launched webcam window. The webcam light remains on and both the terminal and the webcam window did not crash or reported any errors when left on for 10 - 15 mins. The webcam window never updates during this period.

Some other techniques used to interface the USB camera included:

  • Using a Logitech C920 HD Webcam, which yielded the same result.

  • Using OpenCV4Tegra library, which yielded the same result however with the following error shown on the terminal:
    VIDIOC_QUERYCTRL: Input/output error
    Width x Height = 640 x 480
    select timeout
    select timeout

Information on system setup:
The system is currently on ubuntu 14.04.
The USB webcam, keyboard, and mouse are interfaced with the board through a generic USB 3.0 hub.

The overall goal of interfacing the webcam with the Nvidia Jetson TK1 board is to run some image processing tasks using the OpenCV library on the live webcam’s video feed.
Any assistance on this matter will be greatly appreciated. Thanks in advance everyone.

Please check if you can see video preview by running the command:

$ export DISPLAY=:0(or 1)
$ gst-launch-1.0 v4l2src device=/dev/video0 ! videoconvert ! xvimagesink

Thank you for your quick reply,

I ran the commands using both DISPLAY=:0 AND 1 (was unsuccessful using 1) but no video feed was displayed. The command line outputted the following
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GetSystemClock

However, I did observe that a new window was launched entitled gst-launch-1.0 but the window was not displayed. I also eliminated the USB hub (thinking it may be a potential problem) and connected the camera USB camera directly to the single USB port however, I observed the same results as with the USB hub.

Thanks again for your response

We can run the command successfully. Please check dmesg to see if your camera is well enumerated like:

[   45.393560] usb 1-3.1: new high-speed USB device number 16 using tegra-xhci
[   45.548339] usb 1-3.1: New USB device found, idVendor=0bda, idProduct=573e
[   45.558599] usb 1-3.1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[   45.566775] usb 1-3.1: Product: USB Camera
[   45.571058] usb 1-3.1: Manufacturer: 317GAWCM008LON33701F
[   45.576653] usb 1-3.1: SerialNumber: 200901010001
[   45.588772] uvcvideo: Found UVC 1.00 device USB Camera (0bda:573e)
[   45.601088] input: USB Camera as /devices/platform/tegra-xhci/usb1/1-3/1-3.1/1-3.1:1.0/input/input12