USB2.0 cannot be recognized in Jetson AGX Xavier

Hi,
when I plugged in a USB2.0 disk in Jetson AGX Xavier dev board, I found it cannot be recognized.
[0004.119] I> Loading kernel & kernel-dtb from removable storage (6)
[0004.130] W> No valid slot number is found in scratch register
[0004.131] W> Return default slot: _a
[0004.136] I> USB Firmware Version: 60.05 release
[0004.590] E> failed to initialize xhci controller
[0004.591] E> Error in init of XUSB host driver, err: 79790026
Please help to explain me the reason.

PS: Is USB2.0 supported on Jetson AGX Xavier dev board?

Thanks
BR
Yaccor

There are both USB2 and USB3 ports.

Which physical connector are you using? Is the cable of good quality?

Hi,
Thanks for your reply
On the legacy JAX board, there’re 2 USB type C ports. I inserted a usb2.0 disk via a c->b converter, but the disk cannot be recognized. log is shown in my previous post.
Could you please help to explain the error in the log?
Is there any config needed?
Thanks

I am not familiar with that board, but every board must have adjustments to the device tree to route alternate wiring schemes to the right place. This is the custom part of a board support package, and the carrier manufacturer would have to provide that information. The short description is that the default device tree expects the developer kit carrier board or a 100% exact clone (electrically).

Well, maybe you mean the default Jetson Xavier developer kit. If so, please mention this. If this is the case there may be signal quality issues with the converter.

Hi linuxdev,

Thanks a lot for your kindly reply.
Sorry for my late reply.
I’d spent time on looking through the forum on topic of USB.
Our board only uses USB2.0, one typeA, two typeB. The arrangement is shown below:
$$$ USB2-3 usb G10/G11 typeB host
$$$ USB2-0 usb F12/F13 typeA host
$$$ DEBUG_UART_TX/RX H62/K60 typeB

And in the failed log, I found
[ 6.847811] tegra-xusb 3610000.xhci: USB2 port 0 has OTG_CAP
[ 6.849997] tegra-xusb 3610000.xhci: USB3 port 2 has OTG_CAP
[ 6.858599] Could not get extcon-dev /xhci@3610000:id(0)
[ 6.864828] tegra-xudc-new 3550000.xudc: PMQOS CPU boost enabled
[ 6.867258] Could not get extcon-dev /xudc@3550000:vbus(0)
I think this should be a usb extcon init failure which leads to the USB2-0 and USB2-3 cannot be recognized in ubuntu.

From the forum discussion on USB before, I think the following should be modified:
(1) ucsi_ccg should be disabled
(2) tegra_xudc should be removed
(3) usb3.0 should be removed in xusb_padctl and tegra_xhci

Could you please help to point if it’s right and is there anything more need be done?

Thanks a lot

I believe that those steps are correct, but I can’t be 100% certain. The PINMUX spreadsheet is the normal method for modifying the device tree (the spreadsheet has macros and is a bit more thorough than manually editing the device tree…I tend to just edit the device tree to make individual changes, but when you are starting with a custom board the spreadsheet probably makes more sense…or at least studying this would help in understanding customizing layouts). You might go here to search for “pinmux” (then pick Xavier to narrow it down):
https://developer.nvidia.com/embedded/downloads#?search=pinmux

Hi linuxdev,

Thanks a lot for your kindly reply.
I’ll try and check it.

Thanks

Hi linuxdev,

Thanks for your support.
The issue had been fixed.

BR

Hi jiangch0126

I have the same problem about USB 2.0 configuration. Could you please tell me the final solution is to modify the PINMUX spreadsheet or to follow the three steps to modify the device tree ((1) ucsi_ccg should be disabled; (2) tegra_xudc should be removed;(3) usb3.0 should be removed in xusb_padctl and tegra_xhci)?

Thank you

I think what you really need to do is open a new topic and tell us more detail about your board.

If you need to change something in device tree, it probably means you are using a custom board. However, I see no such info is mentioned. Thus, you better clarifying that first.

Thank you so much, I will open a new topic about my question soon.