USB3 port not providing continuous power?

I plugged a Logitech “Unifying Receiver” dongle into the USB3 port on the TK1 and have noticed intermittent connectivity from the paired wireless keyboard unless the TK1 is under load.

If I run the “smoke particles” CUDA Sample then the wireless keyboard remains responsive.

If the TK1 is idle then the wireless keyboard seems to drop its connection every 5-10 seconds.

Anyone else see this?

I assume the workaround is to connect a hub to the mini USB port.

Is this the Logitech “Unifying Receiver” you are using:

And what keyboard? Any other devices connected as well?

It’s a standard unifying receiver and a Logitech K700 keyboard. No other devices as the K700 has a mousepad.

Could you try if the answer in the thread below helps:

I.e. set CONTROL_USB_AUTOSUSPEND=0 in /etc/laptop-mode/conf.d/usb-autosuspend.conf?

Ah, that’s exactly the issue but there is no laptop-mode.

Digging into the USB device list shows that ‘autosuspend’ is set to 2 seconds and the ‘level’ setting allows suspension.

Still figuring out the best way to override these values…

Does this help? It is device-by-device but it might be helpful…

Yeah, I tried that approach earlier but am confused why I can’t overwrite the power/level and power/autosuspend values.

I punted and am using SSH.

I also suspected autosuspending or power management to be a problem with the microsoft kinect ( see : https://devtalk.nvidia.com/default/topic/751916/embedded-systems/microsoft-kinect-with-jetson-tk1/?offset=8#4239098 ) , but i’m stuck at the same point. It seems not easy at all to change these values. I will post again in case i find a way to do so.

Regarding TLP and kinect, see also : https://groups.google.com/forum/#!topic/openkinect/42LX71-1CNI

Forgot to mention that you need to “sudo su” and then overwrite the setting with “echo -1 > /sys/module/usbcore/parameters/autosuspend”.

A plain “sudo echo -1 > …” doesn’t work.

But I haven’t tested to see if this fixes my problem as the TK1 is buried in a cabinet and I’ve been doing all my work headless and over SSH. :)

I did test it just yet, and it works! See here https://devtalk.nvidia.com/default/topic/751916/embedded-systems/microsoft-kinect-with-jetson-tk1/post/4239497/#4239497

Thanks a lot!

Sweet! The Kinect + K1 (K1nect?) looks like a great combo.

Also, a terser way of overwriting autosuspend is:

sudo sh -c "echo -1 > /sys/module/usbcore/parameters/autosuspend"

Hi, have anyone tried with Kinect2 or SoftKinetic DepthSense?