Use emlid reach device on TX2 but can't be detected.

Hi,

Recently I tried to use a GPS. At first I tried on my laptop which is ubuntu 16.04 but it only show up in “lsusb” but not in “/dev”. Then I saw someone has the same problem, and fix it by this “https://github.com/asymingt/rts5139” After that I tried it on TX2, however it can’t be detected with the command “lsusb”.(In fact it showed up for a few seconds “intel corp” then disappered.) I use the solution on laptop, but it didn’t work. So I decided to use “buildJetsonTX2Kernel” to add module into my system. The device is Emlid reach which is a GPS made by intel Edison and the module should be “RTS5129”. However I can’t find the module in Kernel. How should I fix this issue?Thanks

Sincerely

I don’t have such device, so what I’ll propose is pure speculation.
You may waste some time with this, sorry in advance if this happens.

When configuring kernel, you may go to device drivers and:

  1. In menu Multifunction device drivers, enable Realtek USB card reader.
  2. In menu MMC/SD/SDIO card support, enable Realtek USB SD/MMC Card Interface Driver.

Thanks for your reply. It makes sense.

I enabled both Realtek USB card reader and Realtek USB SD/MMC Card Interface Driver, however it still not worked. Tx2 still can not detect the device.

“However I can’t find the module in Kernel. How should I fix this issue?Thanks”

-> Could you share what is going on here?

FYI, even if the device does not function due to a missing driver I would think “lsusb” would show the device exists. If not, then there is probably a hardware issue involved. It wouldn’t be unusual for a USB hardware problem to be fixed by trying a powered USB HUB instead of one which draws power from the Jetson.

Hi WayneWWW,

I tried to search “RTS5129” in Kernel but didn’t get it. But I think “Realtek USB card reader” and “Realtek USB SD/MMC Card Interface Driver” can replace it.

Hi linuxdev,

Thank for your answer, and it fix the issue. As the GPS module’s LED is work normally, I didn’t think about if the power supply enough. Now it can be detect after adding a powered USB HUB. If anyone can detect device by “lsusb” but “ls -l /dev/tty*”, then you can try to build a kernel.
Thanks

@jo679513. I have the same problem. How did you power your Tx2? Which powered USB hub did you used?