Use of SDK manager to setup Jetson AGX Orin

Hello everyone,

I’m not sure I am in the right section of the forum, so feel free to move it accordingly.

I bought a jetson agx orin and installed it in headless mode using a Mac, and everything worked fine.
Then I added an M.2 SSD and wanted to boot on this drive. I did it successfully with my previous jetson AGX, using jetsonhacks tools, so I thought I would reuse those tools to do it with my new Orin.
However, their github page mentions that it is now supported by nvidia and that we should use the sdkmanager to do it, before installing anything. Their github page remains just for history.
And here I am, with a brand new laptop and Ubuntu 22.04, as it seems that the latest version of the sdkmanager supports Ubuntu 22.

However, when I try to use the sdkmanager, this is what I get, failing at step 1 with target OS mentioning an error I don’t really get:

Sorry for the long explanation, but could someone help me here ?
Thank you very much in advance guys.

Host: Ubuntu 22.04 with sdkmanager 1.9.1
Target: Jetson AGX Orin 32GB


I had the same issue. The only way I was able to get the sdkmanager to work was to install on an Ubuntu 20.04 machine. Building and flashing the Orin from source works on Ubuntu 22.04.

Arghh, seriously ?

Anyway, thank you very much for your feedback.
I was indeed able to build from source, but my goal for restarting the whole process is to be able to use the sdkmanager to setup the M.2 SSD as boot drive

Same here. Have look at SDK Manager: No available releases for host OS: ubuntu 2204. You will have an option to select M.2 instead of the default eMMC. Also unselect “Host Machine”, unless you really mean it. Good instructions to follow in “How to use SDK Manager to Flash L4T BSP” section: Jetson AGX Orin Developer Kit User Guide - Two Ways to Set Up Software | NVIDIA Developer.


Thank you for your help.
In the end I installed an ubuntu20.04 as dual boot on my laptop.

Anyway, I was able to use the sdkmanager to setup the jetson, and I could choose either the default eMMC or the NVMe, so I guess this part is now alright.

However, I’m still in the process of installing all this, my Orin is plugged to my laptop via the supplied USB-C cable and the install now fails, mentioning a network issue.

The thing is, my laptop can ping the jetson on said ip address, and if instead of connection through USB I choose connection through ethernet (I also plugged an ethernet cable into the jetson as this USB option seemed to fail), I get the same error although my laptop can also ping the jetson on its ip address.


Now, when looking at the specific error:
ssh -F /dev/null -o PreferredAuthentications=password -o PubkeyAuthentication=no -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -o ConnectTimeout=5 jetson@ ‘ping -c 3 || wget --spider -T 5 -t 1
I see a ping to And for some reason, I fail to ping this specific domain (although I can ping or

EDIT: I realised these commands are ran on the jetson, but the results are the same. Ping to fails, but ping to or successes on the jetson.

I must admit that I don’t know what I should fix, as I’m not sure of the issue here.
Would anyone have an idea of what the problem is, and what I should do to fix it?

Thank you for the esteemed help.


Anyway, I guess at this point my primary purpose is fulfilled, which was to use the sdkmanager to setup the jetson to use the M.2 SSD.
I can now continue the install using the Debian packages, as suggested by the setup flow schema shown in pauljurczak linked thread.

Thank you all for your help.

EDIT: after deciding to complete the install process using the debian packages I clicked on ‘skip’, and then the install went on successfully…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.