Use USB0 as host usb on Orin NX custom carrier board(JP 5.1.2)

For a real Orin Nano devkit, you should see such log.

[   64.313591] fusb301 1-0025: fusb301_work_handler: int_sts[0x04]
[   64.327406] fusb301 1-0025: fusb301_work_handler: int_sts[0x02]
[   64.327417] fusb301 1-0025: fusb301_detach: type[0x08] chipstate[0x06]
[   64.327503] fusb301 1-0025: fusb_update_state: 1

lsusb.log (23.6 KB)
dmesg.log (70.9 KB)

Attached the log we just tested with a usb mouse connected on the type C port of NV devkit.

@WayneWWW

could u please share the dts settings wrt the board you have tested on.

@san1998

Could you really try to understand the situation?

We are NVIDIA moderators. All the boards we test is the NV developer kit. The device tree from sdkmanager is for this kind of board.

I have no idea about what you are asking for when you already have this kind of thing on your side…

The problem on your side is none of the board you have there is really a NV developer kit…

@WayneWWW
Do we have an Orin NX carrier board (P3768) schematic file available?

Yes, such schematic is over the website.

@WayneWWW

Hello,

First of all we did test this I.e USB0 as host mode on Xavier carrier board. Even in that the FTDI device doesn’t get detected. There is no difference in Xavier carrier board schematic and our custom implementation. we have pulled USB0_VBUS_DET* to ground by default as this is the line

Also in the above message you told to connect a mouse to USB0 I.e J5 connector of P3509_A01 carrier board. There is no 5V power coming from the carrier board to the J5 connector !! how will the mouse work? there is only USB0_VBUS_DET* which is used to detect USB when laptop is connected to this port (USB0). There is no 5V power coming from the carrier board to the J5 port for the mouse to work! correct me if i am wrong. The schematics page of this USB0 J5 connector says MICRO USB (DEVICE MODE ONLY).

In our case USB0_VBUS_DET* is pulled to ground by default so the the SOC detects the FTDI chip which is connected on the USB0 port. But it doesn’t work.

I hope you understand the problem.

Thanks

Hi @nithish ,

Sorry to ask this. Are you the colleague of @san1998 ? I just hope it is not someone who is jumping into and affect the original owner of this post.

Back to your question.
I think there is a weird mistake. We are all talking about p3768 carrier board which is the real “Orin Nano/NX” devkit. And only that one has a type C on it…

I didn’t tell anything about p3509 of Xaiver board. Not sure why this thing comes out.
Also, it is pointless to discuss about p3509 at all because the micro usb port on it was designed as device mode only. It is hardware limitation. Nothing to do with how much effort you are doing in software… You know that too.

Just a reminder, when I said “Orin Nano devkit”, it means Orin NX devkit and it is p3768 board. If want to talk about Xavier NX devkit, which is also working for Orin NX module, I would say it as “p3509” and won’t call it Orin NX devkit…

Hey,

Yes, we are colleagues :)

Lets start fresh!!

We have p3509 which has micro usb connector. USB0 is exposed on J5 connector of p3509. In otg mode, When we connect a micro USB cable from our laptop to the J5 micro USB connector, USB0_VBUS_DET* is pulled low and USB0 detects a device. correct?

Now we have a FTDI chip on the USB0 line. with USB0_VBUS_DET* pulled low by supplying 5V to the VBUS pin on the micro USB connector so that SOC detects the device. But it doesn’t !

If USB0 is in host mode then the FTDI device should get detected.

I hope you are clear about the issue ?

Thanks

Hi,

OK…I totally know your issue but I also hope you could just read my previous comment…
There is nothing for me to do with your usb issue if you want to use p3509…

Hey Wayne,

What do you mean by with “your USB issue” ?! You are responsible to fix customer issue right ? We tried all solution you suggested !! Can you address this problem YES or NO ? Why do you say you have nothing to do if we want to try on P3509 ? P3509 is nvidia carrier right ?

Thanks

Try to focus on technical things first… This is not about who is responsible for issue or not.

Please read my previous comment… If don’t know which part, let me post a screenshot to you.

Also, you told us to “start fresh”. Thus, actually you tried nothing of my suggestion either. All previous suggestion was for Orin Nano/NX devkit. Not for p3509.

Hello Again Wayne,

I am attaching our schematic of our USB0 implementation and a image which shows what has changed from P3768-A04 orin nx carrier board to our custom board.

  1. When i connect a FT4232 to USB PORT J5 on P3768 it gets detected. ( Using
    FT4232H-56Q MINI MDL EVM board ) The board takes power from J5 PD.
  2. In our custom board we do not have U54 FUSB301TMX or U37 PI3DBS12212AZBSEX_EOL or Q54, U55 ( please ref WWWWW.PNG attached). USB0 pins of SOM is connected to USB PINS of FT4232H CHIP ( Please ref attached schematic EEEEEE.pdf)

Question,
What all should we disable to remove the dependencies of U54, U37,U55 in the driver for the USB0 to work.

We understand U54 FUSB301TMX needs to be disabled. There is a interrupt pin in U54 which is connected to USB0_VBUS_DET* and it goes to the SOM.

As you can see in our schematic we are not using USB0_VBUS_DET* and it is left unconnected.
EEEEEE.pdf (216.1 KB)

Thanks

Actually, if USB1 can work fine, then you just copy most of content from USB1 to your USB0.

The document is already posted long time ago. Rest of part is just copy and paste from USB1. Hope this is not difficult to you.

@WayneWWW

After changing USB0 to host mode and disabling it in xudc and disabling usb_cd node, we are now able to detect the FTDI on our custom board on USB0 port.

Thank you.

1 Like