Used on TX2 realsense unstable problem

I use jetpack3.1 version to install realsense TX2, is I use R200 test.But, at the time of test is always unstable.Situation is as follows:
When running the sample for the first time, the program running, as shown in figure

Run the sample again, there will be a box, and then began to report errors, such as the contents of an error

Unplug the USB port of external realsense camera, in the plant, and the sample can be normal operation, the but again run once, or there will be mistakes on it.I don’t try to R200, with an ordinary camera run a I write programs to open the camera, won’t appear the problem above.This is why ah.If there is any can help to solve it.

Hi,
Is it specific to realsense R200? Are you on r28.1? What sample do you run to see the issue?

Apologies to reopen this thread. I have R28.1 and using R200. I have not tested any other camera’s and facing the same issue. Any solutions thus far? Even a script that needs to be ran at every program shutdown is a fix for now.

Thanks alot for the link.

I have tried the multiple solutions for Intel Realsense on Jetsonhacks. Honestly, the camera works for me right out of the box. and the tutorials did not do much visible difference. I am facing the exact issue as stated above where the camera runs well only once. On CTRL-C, the shut down raises a flag in SIGTERM which blocks and gives errors on any subsequent launches.

ryanz2v0a,
Which sample are you referring to? IF your own camera apps won’t have this re-run issue, did you use it for more intensive testing to your camera configuration? We will check more details if you can let us know the sample details. Thanks.

could you elaborate on “samples”

Hi,


So after following this page, the intel camera still does not work?

We don’t have experience in running this camera, but some other users have tried it and share it on the webpage. Ideally it should help your case.

Yea, I’ve visited and followed the guides there. It’s not that the camera does not work, it’s more of that the camera works only ONCE. Weird SIGTERM error that gets called on exit.

I’ve posted a video capture of my terminal that shows the steps I did to recreate the error.
https://asciinema.org/a/eT7UHkWnnhdduTn3RPHoX4125

Problem solved with JetPack3.2