Using 32bits library on a TX2/ Install a R23.X version on TX2

Hello,

For a project, I have to use a vision library: Halcon, which comes only in a 32 bits, dynamically linked version for arm processors.
I tried cross compiling using the “GCC Tool Chain for 32-bit BSP” given on the nvidia website.
While the cross compilation is working fine, when I tried to run on the TX2, I have the following message: ./test_1: No such file or directory.
I think it comes from the fact that it cannot find the “/lib/ld-linux-armhf.so.3” and the 32 bits library on the system. Which make sense since the R28.1 installed on the TX2 is 64 bits only.
When I cross compile using the 64 bits GCC tool chain (but without the library, just a test project), it works fine on the TX2.

The question is how can I make a 32 bits library run on the TX2?
Is it possible to install a R23.X or R24.1 version on the TX2? On the Nvidia website, the first version listed for the TX2 is the R27.1, but it is not clear if an older version would run on it. I would try by myself, but prefer to have an opinion/ previous experience first.

According to this post:
https://devtalk.nvidia.com/default/topic/1024791/jetson-tx2/build-run-32bit-application-on-tx2/post/5212916/
It is possible, but quite complicated to install a full 32 bits architecture, but not an easy task. And my knowledge in linux is probably not sufficient to properly run such a task. So if someone knows a tutorial, it would be more than welcome.

Any other idea would be welcome too.
Thanks in advance.

[edit]
Apparently R23.x is not an option:
https://devtalk.nvidia.com/default/topic/1023392/jetson-tx2/flashing-tx2-with-tx1-jetpack/
[/edit]

The TX1 rootfs is not a possibility on the TX2 for releases prior to R28.1.

You would need to add a 32-bit foreign architecture. Though technically possible, this would be quite difficult, and performance would drop quite low.

Thank you for the answer.
I was afraid I would have to install a foreign architecture.