Using/Compiling ArrayFire for Jetson TK1

Hello
I have tried to install ArrayFire on my Jetson board by following the instructions here: http://www.elinux.org/Jetson/Installing_ArrayFire
But when I tried to compile the Hello World program, the compilation fails and syas that it requires CUDA 6.0, but I have CUDA 6.5 installed.

Is there any way to fix this?
Thanks

If you flash to R19.3 you can install CUDA 6.0. I’m not sure if R21.2 is compatible with 6.0 (R21.x was the first L4T version using CUDA 6.5)…the best of all worlds would be if both CUDA 6.0 and 6.5 worked on R21.x, but I have not heard any feedback on this.

Hi

The build instructions for the Open Source version of ArrayFire can be found on our Github Wiki https://github.com/arrayfire/arrayfire/wiki.

This version of ArrayFire is not dependent on a specific version of CUDA and will work with both CUDA 6.0 and 6.5.

Note: Make sure you clone with the git clone --recursive option enabled.