Using deepstream-app on NX with 20 source stream we cannot see any detected/tracked boxes


We converted a Xavier/AGX card into a Xavier/NX card following this link

and what described into
Jetson AGX Xavier as Jetson Xavier NXEmulation Package User Guide

After turning AGX into NX we run on Xavier/NX some tests using deepstream-app and TinyYolo inference Network and working with 4 source streams ( 3 input VideoFiles + 1 rtsp stream ) and producing 4 rtsp output stream, so we got 1 rtspStream connected to VLC and 3 separate videoFiles.

In this condition results were good and we could see detected/tracked persons on both videoFiles and VLC.

Then we tried to test with 8 source streams and 10 and then 20.

When using 20 sources stream we can no more see detected/tracked persons on output videoFiles, so output video is the same of input stream without boxes and without trackID drawned in it.

I tried to search in deepstream-app source code if there is present a maximum limit of detected objects but I cannot find it.

Why we cannot see no more boxes ?
Could it be a problem of deepstream-app bound to NX or is it a specific deepstream-app limitation, common for all cards ?

It is better to file this problem as a bug ?
Which should be the proper container for this bug ? TX2 card ? NX card ?

Let’s know,

There is a reference config file for Xavier:
Please check if you can run it without hitting the issue. If the issue is present, please set sync=0 in [sink0] for a try.

I am already using “sync=0” here below a snippet of my deepstream_config_file_xxxx.txt … evidencing it with “<<<<<<<”

In any case I am usign TinyYolo and not ResNet … but till now I see there was no problem using TinyYolo… and all worked well


sync=0 <<<<<<<<<<<<<<<<<

So once you emulate Xavier as Xavier NX, it fails to run the default config file?
Or it is specific to running TinyYolo?

it is surely specific to running TinyYolo.
So in my test I am using my config file similar
but with yolo configuration details.

and it is correctly parsed and interpreted and deepstream-app start correctly and we see recognized persons and objects till 10 channels, … but over 10 channel we see no more recognised objects.

The main problem is that
-) at 20 channels we do see no more recognised objects

Anothe problem is that from tegrastats we see that GPU is available but total FPS we get are not increasing.
So for example we get 120 FPS (we use interval=3) and GPU could be 50% … but why don’t FPS go to 200 and GPU go to 80/90% ?

Is deepstream-app limiting the maximum level of used GPU ?

We would like to reproduce the failure on Xavier NX and check further. In DeepStream SDK 4.0.2, we have YoloV2, YoloV2_tiny, YoloV3, YoloV3_tiny. Is either one can be used to reproduce the failure? If yes, please share the config file based on the model.