Using docker with the University Licence

Hello there. I have a 1 year licence for developing with CUDA fortran. So far, on my main system, everything was going great until I hit some snags with hardware and linux upgrades. My code stopped working. I hit on the idea of using docker to setup a linux environment similar to my original one where everything worked fine. I’ve created a docker image but it is having trouble with the licence.

The docker process reports this:

pgfortran: LICENSE MANAGER PROBLEM: No such feature exists.
Feature:       pgi-f95-lin64
License path:  27000@
FlexNet Licensing error:-5,412.  System Error: 2 "No such file or directory"
For further information, refer to the FlexNet Licensing documentation,
available at "".

The lmgrd daemon is running outside of the dock. It reports this:

16:27:57 (pgroupd) UNSUPPORTED: "pgi-f95-lin64" (PORT_AT_HOST_PLUS   ) root@e611e15f9c9d  (License server system does not support this feature. (-18,327))

the LM_LICENSE_FILE env variable for the docker file looks like this:


Is this simply a feature I can’t use? Is it not possible to perform such a request to the daemon?
KInd regards


You have a Unidev license, PIN 701732.
This license allows you to develop on a single machine, and you
will also setup a license server on the same one machine you
compile on.

Here is your license for the machine azuma.

SERVER azuma ecf4bb15dcc1 27000
DAEMON pgroupd
… and so on…

ping azuma return ‘’ ?

it should, or if this is a laptop,
ping localhost

should return ‘’ and may be a better choice.

One node-locked licenses, it is better to set LM_LICENSE_FILE
and PGROUPD_LICENSE_FILE to the full path to the license file.

Make the license run by

  1. storing the license as $PGI/license.dat

export PGI=/opt/pgi
export PATH=$PGI/linux86-64/16.4/bin:$PATH

export PGROUPD_LICENSE_FILE=$PGI/license.dat

Kill any license service running

ps ax | grep lmgrd
(kill -9 and process ID other than ‘grep lmgrd’)

and then start the license service

lmgrd.rc start

If the license is working
ps ax |grep lmgrd

will should something like

21155 ? S 0:21
/opt/pgi/linux86-64/7.2-5/bin/lmgrd -c /opt/pgi/license.dat

and the source codes should compile.


Thanks for the reply!

I tried another solution which is to run an interactive bash docker session and run the lmgrd daemon inside the dock, then compile. Launching the dock with the same mac address and hostname as the main machine I have the licence for appears to work, although it does seem a little like a hack.