Using fakesink causes errors with rtsp sources

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 6.0 (

Hi, I have a problem with GStreamer application written in C++.

I developed the app which runs custom analytic plugins on multiple RTSP streams.
The application is building the pipeline using rtspsrc, uridecodebinand nvvideoconvert as a group of plugins before passing the data to nvstreammux - next, there are a few analytic plugins and output.

The configuration works fine if the app is outputting video on the screen - only for debugging purposes.

I need to run it on a server without a display. So, I ran into problems - I cut off the part of the pipeline responsible for outputting video and replaced it with a fakesink element. Then a strange thing happened:
None of the RTSP sources was able to connect. The same sources work fine when displaying on screen.

And there are the GStremer logs about the error:

0:00:01.530929294  5481 0x5629a6ad40a0 ERROR                default gstrtspconnection.c:1004:gst_rtsp_connection_connect_with_response: failed to connect: Operation was cancelled
0:00:01.530942068  5481 0x5629a6ad40a0 ERROR                rtspsrc gstrtspsrc.c:4702:gst_rtsp_conninfo_connect:<rtspsrc0> Could not connect to server. (Generic error)
0:00:01.530947899  5481 0x5629a6ad40a0 WARN                 rtspsrc gstrtspsrc.c:7469:gst_rtspsrc_retrieve_sdp:<rtspsrc0> error: Failed to connect. (Generic error)
0:00:01.530958100  5481 0x5629a6ad40a0 INFO        GST_ERROR_SYSTEM gstelement.c:2145:gst_element_message_full_with_details:<rtspsrc0> posting message: Could not open resource for reading and writing.
0:00:01.530979254  5481 0x5629a6ad40a0 INFO        GST_ERROR_SYSTEM gstelement.c:2172:gst_element_message_full_with_details:<rtspsrc0> posted error message: Could not open resource for reading and writing.
0:00:01.530991258  5481 0x5629a6ad40a0 WARN                 rtspsrc gstrtspsrc.c:7548:gst_rtspsrc_open:<rtspsrc0> can't get sdp
0:00:01.531004587  5481 0x5629a6ad40a0 INFO                    task gsttask.c:316:gst_task_func:<task0> Task going to paused

I was able to run the pipeline by changing the rtsp reading part (rtspsrc -> decodebin to uridecodebin), but it has a huge drawback for me - after changing the stream reading is not smooth anymore.

Could you help me, how could I run the app without display and keeping the pipeline with rtspsrc and decodebin?

please refer to deepstrem-app, in it’s configuration file source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt, type=1 in [sink?] means it will use fakesink.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.