Using jetson inference ssd-mobilenet and openCV haarcascade

i trained my own ssd-mobilnet model from jetson inference and it worked fine on jetson nano.
i tested opencv haarcascade alone on jetson nano and it worked fine.
i tried to merge both of them in one code but its not working.
this is the code iam using: opencv-detectnet.txt (1.5 KB)
[OpenGL] failed to create X11 Window.
jetson.utils – no output streams, creating fake null output

and only opencv window is showing with the detection bounding box of opencv only.

any help? thanks.

Hi @daoudma, can you try creating the jetson.utils.videoOutput object before importing cv2?

When OpenCV is imported, it seems to change around the GL/GLX extension loader.

i tried it but i had an error with opencv
ERROR: ImportError: /usr/lib/aarch64-linux-gnu/ cannot allocate memory in static TLS block
i solved it with this command on terminal: export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/

all worked fine.
thank you

OK thank you, thanks for letting us know.