Using jetson-io.py doesn't change camera driver from IMX219 to IMX477

I’m using an Xavier NX on the development board, and have been trying to get two IMX477 cameras from Arducam working.

Since IMX477 should be natively supported since Jetpack 4.6, I used the jetson-io.py script to set the CSI connectors to “Dual IMX477” and rebooted, as described here.

However, launching a preview with gst-launch-1.0 results in an error stating “no camera devices found”.

To check if the driver is installed/enabled, I ran command:

dmesg | grep -E “imx477|imx219|arducam”

Which gave me errors messages for the IMX219. There are no video0, video1 devices under /dev/.

I have tried on Jetpack 4.6, 4.6.1, and 4.6.2. I’ve also tried with and without the cameras connected, as well as with 1 or 2 cameras connected. Cameras are connected correctly, with pins facing the heatsink. I used the SD card image to flash the Xavier NX, it’s booting off a 32 GB MicroSD, with no SSD connected.

Any help would be appreciated!

1 Like

Please consult with Arducam. Looks like native imx477 driver unable working for Arducam’s IMX477 module.

Thanks

Hello,

The dmesg | grep -E “imx477|imx219|arducam” and Which gave me errors messages for the IMX219 imply that you haven’t changed to IMX477 successfully.
Maybe you should provide the full dmesg information so that we can diagnose the problems quickly.
Best regards,
Arducam

Hi,

I have the full dmesg information here: https://pastebin.com/Q703gH5m

hi,

I have the same problem.

But I dit some more testing and I found out that when I used an other Jetson Xavier nx the driver did change and I could use the camera. But after some work on that Jetson I got the same problem on that one as wel.
So it’s looks like a hardware problem to me (it’s not about the camera itself because on other Jetsons and raspberry pi we could use that camera)

Hi,

We are having the same issue with our Jetson Xavier NX and two Arducam IMX477 camera modules. They worked flawlessly on Jetpack 4.5.x but do not on the latest 4.6.2.
The issue indeed seems to be the jetson-io script not switching camera types properly.
dmesg output is similar to user38669, with no mention of IMX477.
This has been marked as solved but I don’t see a solution…

It is not a hardware problem as older L4T versions had no issue switching camera types.

Thank you for your help.

Best regards.

1 Like

Hi again,

I solved the issue by flashing JetPack 4.5.1 using sdkmanager to reset the QSPI flash to an older version able to load the user-custom DTB for dual imx477 cameras, then flashing the latest JetPack on the SD card and using jetson-io.py to switch to dual imx477.

nVidia, be aware that the user-custom.dtb generated by Jetson-io is not loaded by the bootloader from JetPack 4.6 onward!

Thanks for your help.
Regards.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.