Using NVEncode with Black MAgic decklinkvideosrc

Hi All
We are trying to get source video using Black Magic Infinity Pro card and use NVEncode provided by Nvidia. But we are note able to link the two together.
We are using Gstreamer to grab the video and encode and stream.
GStreamer pipline:
gst-launch-1.0 deckinkvideosrc device-number=1 connection=HDMI ! videoconvert ! nvh264enc ! h264parse ! mpegtsmux ! rtpmp2tpay ! udpsink port=5054 host=10.0.0.158 —This is not working

Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
/GstPipeline:pipeline0/GstDecklinkVideoSrc:decklinkvideosrc0: hw-serial-number =
Got context from element ‘nvh264enc0’: gst.gl.GLDisplay=context, gst.gl.GLDisplay=(GstGLDisplay)"(GstGLDisplayX11)\ gldisplayx11-0";
Setting pipeline to PLAYING …
New clock: GstSystemClock
/GstPipeline:pipeline0/GstDecklinkVideoSrc:decklinkvideosrc0.GstPad:src: caps = video/x-raw, width=(int)720, height=(int)486, pixel-aspect-ratio=(fraction)10/11, interlace-mode=(string)interleaved, framerate=(fraction)30000/1001, field-order=(string)bottom-field-first, format=(string)UYVY, colorimetry=(string)bt601, chroma-site=(string)mpeg2
/GstPipeline:pipeline0/GstVideoConvert:videoconvert0.GstPad:src: caps = video/x-raw, width=(int)720, height=(int)486, framerate=(fraction)30000/1001, pixel-aspect-ratio=(fraction)10/11, format=(string)NV12, interlace-mode=(string)interleaved, field-order=(string)bottom-field-first
Caught SIGSEGV
Spinning. Please run ‘gdb gst-launch-1.0 8839’ to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core.

With testvideosrc it works
gst-launch-1.0 testvideosrc ! videoconvert ! nvh264enc ! h264parse ! mpegtsmux ! rtpmp2tpay ! udpsink port=5054 host=10.0.0.158 —This is working

Thanks for help
Jaskarn Kalsi