Using Nvidia driver with Mosaic on RedHat 7/8

I have a 4 monitor setup 2 - 49" Dell U4919DW and 2 - 27" Dell U2722D
The 27" monitors are rotated on each side of the 49" monitors stacked on top of each other.
I have two Quadro P2000 cards and connect the 49" monitors to one card and the 27" monitors to the other.
Using Nvidia Driver 470 on Oracle Linux 7.9/ soon to be 8
I want to have Monitor0 and Monitor1 contain Modelines for the native resolutions of each monitor type.
I also want to have Device0 and Device1 to add addition configuration options for the monitors that are connected to each card.
My Question:
I want to use base mosaic to bind Monitor0, Monitor1, Device0, Device1 in the Section “Screen”
After scouring the internet for a week I can not find anything that describes how this could be done…
Can something like this be done??
Could someone provide examples of what this could look like…
I think I have provided enough detail what I’m trying to do if not please ask me…
Many Thanks for any help…

I’m a bit puzzled regarding what you want to achieve.
In general, this doesn’t work this way. In xorg.conf, you only configure the primary gpu and turn on basemosaic. The other gpus will be auto-added clones.
Adding modelines (what for?) for DFPs don’t make sense, those are read from edid anyway.
Specific setting can be done by using metamodes, see:
Though this also depends on the DE, e.g. KDE/Gnome’s monitor managers often don’t like this.

Thanks for your input…I have viewed the link you provided and would agree in general a mosaic of monitors detected via EDID and
a pair of like Quadro video cards requires very little configuration where the HW generally is abstracted to a single monitor, device and screen.
I have 2 Dell U4919DW and 2 U2722D monitors which we are using with Mosaic…
These are simply not detected via EDID which is complicating the configuration…
Below is the xorg.conf I will be testing tomorrow, hopefully I can dial this in.
We are using two Nvidia Quadro P2000 Cards on a Dell 7920R computer
StarTech DP2HD4K60S DP to HDMI adapter, Cosemi AOC HDMI cables… (Note this is not my choice, it’s what I have to work with…)
I believe the Dongle cable combo is blocking the EDID signal from providing the correct data for our monitors.
These cables do allow more than enough bandwidth and we actually had this setup working perfect with the Nvidia Driver 418, when we upgraded
recently to the 470 driver all we got was black screens.

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 470

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”

generated from default

Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”

generated from default

Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”

HorizSync source: edid, VertRefresh source: edid

Identifier “vxmon0”
VendorName “Dell”
ModelName “U4919DW_U2722D”
Modeline “5120x1440R” 469.00 5120 5168 5200 5280 1440 1443 1453 1481 +hsync -vsync
Modeline “2560x1440_30.00” 146.25 2560 2680 2944 3328 1440 1443 1448 1468 -hsync +vsync
Modeline “2560x1440R” 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync
Option “DPMS”

Section “Device”
Identifier “vxdev0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro P2000”
Option “DPI” “108 x 108”
Option “ModeValidation” “NoEdidModes, NoVesaModes, NoXServerModes, NoEdidMaxPClCheck, NoMaxPClkCheck, AllowNonEdidModes, AllowNon60HzDFPModes”
Option “UseEDID” “false”
Option “UseEdidFreqs” “false” #May be redundant…

Section “ServerFlags”
Option “BlankTime” “0”
Option “StandbyTime” “0”
Option “SuspendTime” “0”
Option “OffTime” “0”

Section “Screen”
Identifier “Screen0”
Device “vxdev0”
Monitor “vxmon0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” "DFP-6
Option “DPI” “108 x 108”
Option “HorizSync” “GPU-0.DFP-6: 25 - 115; GPU-0.DFP-4: 25 - 115; GPU-1.DFP-2: 30 - 90; GPU-1.DFP-0: 30 - 90”
Option "VertRefresh "“GPU-0.DFP-6: 24 - 86; GPU-0.DFP-4: 24 - 86; GPU-1.DFP-2: 49 - 76; GPU-1.DFP-0: 49 - 76”
Option “metamodes” “GPU-d0c9bf33-c625-481f-3586-3e12738e2796.GPU-0.DP-6: 5120x1440R +1440+0, GPU-d0c9bf33-c625-481f-3586-3e12738e2796.GPU-0.DP-4: 5120x1440R +1440+1440, GPU-4e04c69b-34ea-6d01-7532-befab61094ce.GPU-1.DP-2: 2560x1440_30.00 +0+0 {rotation=right}, GPU-4e04c69b-34ea-6d01-7532-befab61094ce.GPU-1.DP-0: 2560x1440_30.00 +6560+0 {rotation=left}”
Option “MultiGPU” “Off”
Option “SLI” “off”
Option “BaseMosaic” “on”
SubSection “Display”
Modes “5120x1440R” “2560x1440_30.00” # will be trying both 30Hz and 60Hz modelines…
Depth 24

I’d rather extract the edid, then use the CustomEdid option to load it from file.

I like this idea, it may very well be a solid solution…
It will take me a few days to collect the .bin files, setup and test but will report back with xorg.conf if it works…
If it does not work I actually got this setup working yesterday, xorg.conf is ugly and I can’t tell you; for sure, why
it works will take more testing I think to sort.
Thank You for the suggestion…