Using sdkmanager to install jetpack on orin nx but canot detect

Hi,I tried to use sdkmanager to install jetpack on orin nx,but the board cannot be detected by sdkmanager in step 1 and if I set the account manually,it still fail anyway,the board is orin nx 16GB,and my host device is Linux PC,when I type lsusb,it can be show in terminal

Sorry, didn’t notice the name.

Please share me the dmesg of your device after you boot up.

You mean the orin nx board?

Hi @MaxineZ

  1. 我不確定你有沒有清楚狀況. 你燒錄已經做完了所以不用再燒. "flash"跟 “install sdk” 這兩件事情是可以分開做的. SDKM 上面可以選擇你要做哪件事
    flash做完之後就已經可以開機了 要確認usb能不能動就是我為什麼請你開這個新issue的原因.
    你不用再貼一次你的sdkm flash 的圖片了 那跟現在的問題毫無關聯.

  2. 對, 從orin nx board上抓dmesg

  1. I am not sure if you know the situation or not. You already done the flashing. “flash” and “install sdk” are different things can could be done separately.
    You can boot the device after you flashed the board. Whether the usb port can work or not is what we need to check now and why I asked you to file new topic. You don’t need to post the sdkm flashing screenshot again. They are not related to current issue.

  2. Yes, dump the dmesg from orin nx.

Ok,what I want to do is install sdk,I know that flash is finished,I don’t know if I can separately install sdk

dmesg.txt (71.6 KB)
And here’s the dmesg,I am not sure if you want it.


  1. 其實安裝sdk沒有什麼特別的學問, 就是特過網路把檔案從host上面送過去然後在orin上面安裝.
    由於我們預設是用usb network進行安裝, 所以usb線要跟你的host接著

  2. 現在看起來你的usb port好像出了問題, 這個usb network沒辦法起來. 所以我才請你開一個新的topic然後把log給我

  3. sdkm上面可以選擇要不要燒錄… 有個地方可以勾選/不要勾選

  1. There is no special trick in install sdk. It is just through the network (IP/ssh) to send file from host to orin and then install. The default network is based on the usb so you have to connect the flash port between jetson and your host

  2. Current situation is this usb network seems failed so I need to check your dmesg (kernel log) to identify why usb fails.

  3. You can “click” in the sdkm GUI to select whether to flash the board or not.

   75.436181] tegra-xudc 3550000.xudc: EP 0 (type: ctrl, dir: out) enabled
[   75.446103] l4tbr0: port 1(rndis0) entered blocking state
[   75.446119] l4tbr0: port 1(rndis0) entered disabled state
[   75.448377] device rndis0 entered promiscuous mode
[   75.463290] l4tbr0: port 2(usb0) entered blocking state
[   75.463305] l4tbr0: port 2(usb0) entered disabled state
[   75.463573] device usb0 entered promiscuous mode

看起來usb network好像被block. 請問你有其他host可以測試嗎?

It looks like the usb network has been blocked. Do you have other host to test?

Do you mean my host PC?And is there anyway to unlock the usb network,it spend time for me to get another PC

或是你可以直接在sdkm上面改成用etherent安裝. 就可以先不用管usb network這件事情了
基本上只要你的host跟jetson之前能ping到對方. 不管這個網路介面是誰(etherent/wifi/usb), 都可以安裝

Or you could just change to ethernet to install and then you could ignore the usb network issue for now. Basically if your host and jetson can ping each other through a IP, then no matter what interface (ethernet/wifi/usb) it is , it should be able to work for installing sdk.

I tried connect the host and board with network cable but it also fail,maybe I can try using wifi

請問你"fail"的意思是什麼? sdkm上面那個detect不到board的錯誤只能detect usb network.
你就繼續往前做 然後選擇只裝sdk.

What does that mean “fail”? The “cannot detect board” on sdkm can only detect the usb network.

Please just select to install sdk only and proceed.

But if the board cannot be detected,I cannot choose the board to install sdk,I have only choice to quit sdkmanager


You can still choose which board to use manually on the sdkm GUI.

I mean this window,if the board is not conneted,I can only choose skip and quit sdkamanager,isn’t it?

這裡就是要請你要把connection從"USB" 換成Ethernet… 我上面提到的東西就是這個意思…

You have to change the connection from “USB” to “Ethernet”… that is what I mentioned in previous comment…

Yes I tried that, but it still cannot be detect

請問你確定你的host能用你給的IP ping到jetson嗎?

Are you sure your host can ping the jetson with the host IP you provided?

I want to know that if connected,will the board be assigned with an IP address?I can only find the default IP on the board

照理來說ethernet cable接上之後, 你的網路環境(switch/router)會透過dhcp 把IP assign給jetson.
如果這件事情沒發生的話, 麻煩把網路線接上jetson, 透過serial console再抓一次dmesg然後貼過來

Basically your ethernet environment (switch/router) will assign the IP to jetson through dhcp after you connect the ethernet cable.

If this this didn’t happen, please connect the etherent cable to jetson, dump the dmesg through serial console and share it here again.