Using self designed AGX Xavier carrier board make the AGX Xavier performance lower?

Dear Sir,

We have designed a carrier board for our customer, and when they tested the performance of Xavier, they bringed one problem about the performance of Xavier:

  1. Our customer used their own computer vision algorithm (using CUDA to decode local video files)
  2. Xavier devkit running 18 video files(1920x1080 6fps mp4 local video files), test result is fine(no frame is lost)
  3. Xavier self designed board running the same 18 vidoe files(1920x1080 6fps mp4 local video files), test result is failed(after 2minutes, some frames are lost), but running 16 video files(1920x1080 6fps mp4 local video files), test result is fine(no frame is lost)
  4. We use the same AGX Xavier Module, and we had checked the temperature, Memory/GPU/CPU usage, MAXN Power are the same (./tegrastat)
  5. their software run based on JetPack4.1, DS3.0

We can’t re-produce the problem in our office, so can you give some advice about how to use CUDA to test AGX Xavier performance?

Thanks.

Hi, did you check the log file to see if any throttling on performance? Did you read all thermal zones value to see if any difference between custom board and DevKit? If all parameters are really same, there should be a same performance.

Dear Trumany,

We have checked the log file(no errors, no throttling), and all thermal zones, there seems no difference between custom board and DevKit.

We have submitted to NV Online bug list toow.