Using SPI on Jetson TX2 with Auvidia J120 carrier board

Hello,

im trying to use SPI over J13 (10 pin connector on the J120(TX2) board) and get no signals out on the connector pins. If i loop MISO/MOSI (pin 3,4) and run the spidev_test it returns always only 0x00…0x00.

What i’ve allready done:

  • patched and installed JetPack 3.2.1 (3.3 also tried) like it is described in the installatiions guide for J120 of auvidia.
    After that i’ve got the SPI devices(spidev1.0, 2.0, 2.1, 3.0, 3.1) activated in linux. -> But, there were no reaction/signals on J13 by running spidev_test on all availible spidevX.X

SPI interface connector J13 seems to be connected to GPIOs on TX2 like below:

GPIO_WAN5 (SPI2_CLK) — J13.Pin2
GPIO_WAN6 (SPI2_MISO) — J13.Pin3
GPIO_WAN7 (SPI2_MOSI) — J13.Pin4
GPIO_WAN8 (SPI2_CS0) — J13.Pin5

than i have changed the device tree and pinmux in the same way like it is described here: https://elinux.org/Jetson/TX2_SPI.

Now the Pinmux looks like this for the affected GPIOS:

Bank: 0 Reg: 0x0243d000 Val: 0x00000409 -> gpio_wan8_ph3
Bank: 0 Reg: 0x0243d008 Val: 0x00000401 -> gpio_wan7_ph2
Bank: 0 Reg: 0x0243d010 Val: 0x00000455 -> gpio_wan6_ph1
Bank: 0 Reg: 0x0243d018 Val: 0x00000401 -> gpio_wan5_ph0

But i still do not get any signals out from J13-Pins(CLK, MOSI, CS0).
I need help. What is wrong here?
Do anyone already successfully worked with SPI on J13 of J120(TX2) board?