Using UART for custom hardware


I want to connect a UART device through IMU connector by utilizing Rx, Tx (and GND) pins. Is some software/os-level configuration required to get it working? I am expecting that when device is correctly wired, that dmesg would show that something is connected, but that is not currently occurring.

Dear marek.piirikivi,
Did you connect the device via IMU port in vehicle harness connector? If so, may I know what you have connected to check?


yes, I connected via IMU harness connector. Device that I have connected is custom. I was able to see and use the device without any issues when I connected it to USB port through UART <-> USB converter. Since the number of USB ports is very limited and I’d like to reserve these for USB devices, I want to cut out the middle-man (UART-USB converter) and connect the device directly via UART.
Device is constantly streaming bytes (so it’s really easy to detect if stream is coming in or not).

I see that there are few more UART connection options (xavier-A (we use A only currently), MCU, IMU (what I tried)). I haven’t tried Xavier-A or MCU connectors (pin-out appears to be the same).

Could you confirm whether additional configuration is required to use UART?

Dear marek.piirikivi,
The Xavier-A UART port is just to connect your host PC and Xavier A via minicom like usb debug port.
From HW point of view, you should be able to connect your device via IMU RS232 port. Let us know if you see any issues


I have tried to do so. If you could tell me that no additional configuration is required on drive, then I can go and re-check all the pins of device male DB9 connector (so that they match of what is described in DRIVE mechanical installation guide). There might be mix-up with Rx and Tx (I could probably re-check them anyways).

Additionally, assuming that connection is correct, what device file should I expect/look for under /dev/ directory. something like /dev/tty** I assume?

Dear marek.piirikivi,
In my knowledge additional configuration is not needed. Could you confirm if you see any change in /dev/tty** list after connecting/disconnecting?

I checked differences between diconnected and connected device and there were none (only ptmx time changed). In addition dmesg does not show any changes in kernel when connecting or disconnecting.
I’ll re-check device and maybe try out if I see anything when I directly connect Tx <-> Rx on IMU connector (as this means that it can send data to itself - just to be clear that cable itself is working correctly).

Update: I tried with MCU connector as well, but the results are the same

Dear marek.pirikivi,
IMU port is enumerted as /dev/ttyTSH1. Could you please check that?

Thank you for your reply. Indeed, ttyTSH1 is correct device.