/usr/bin/ld: cannot find -lopencv_dep_cudart

Wayne, My error log is just one: Cannot find -lopencv_dep_cudart when i tried to build opencv_tutorials https://github.com/rgiduthuri/openvx_tutorial
after “set(CUDA_USE_STATIC_CUDA_RUNTIME OFF)” doing this in CMAke Lists file, the error I got error: Video not able to open.
Since, this tutorial has some video as an output. you can find that video in files too but it should open on building and running from qt creator.

Hi Eyshika,

I suggest you to move to opencv 3.1 for this test first.
By using that fix “set(CUDA_USE_STATIC_CUDA_RUNTIME OFF)”, it should use cudart instead of opencv_dep_cudart.

opencv_dep_cudart has not ever generated since opencv2.4.10. The “video not able to open” problem may relate to other issues here.

I installed opencv4tegra, do you want me to install opencv only, also it will have less features as I want .

Error log is this:

ERROR: Unable to open:… /tutorial_videos/PETS09-S!-L1-View.avi

This video is actually an output on program which I am running in qt creator as guided by Khronos videos.

I saw the version recommended on the tutorial from you is opencv 3.1.

For the test to be worked, you should follow that first.

Wayne, i wonder if I will move from Opencv4tegra to opencv3 then again back to opencv4tegra(since i will need this in my project) then I might mix up some libraries of opencv and it all mess up.

I think you should try to point out which function call cause the error first.

.