/usr/bin/ld: cannot find -lXmu

Hello, I was trying to get CUDA on my machine (Ubuntu 9.04 x86, GeForce 8800 with driver version 190.32) so I ran the installer for the toolkit then the sdk like the instructions said

Then I added /usr/local/cuda/bin to my PATH and /usr/local/cuda/lib to my LD_LIBRARY_PATH

After that, I ran make and I got the error above “/usr/bin/ld: cannot find -lXmu”

Did I type something wrong? I’m guessing my LD_LIBRARY_PATH is messed up but I cant see where or why.

these are my environmental vars

echo $PATH




If any more information is needed i can post it … tried to google “/usr/bin/ld: cannot find -lXmu” but i couldn’t find anything … WHY DID YOU FAIL ME GOOGLE!!! WHY???

I don’t use Ubuntu with CUDA, but I believe all you need to do is type

sudo apt-get install libXmu-dev


man…how did you know that so easily!!! it worked i also had to install the dev files for glut

I guess im just to used to a config file yelling at me for not having a file XP

EDIT: then again lb is a linker and you need the dev files to link >.> what doesnt kill yah makes you stronger should apply to intelligence as well XP

EDIT2: Anyone got a reason why some of the cuda apps just destory my comp? Basically i run it and it runs for about 2-3 secs and then my entire comp goes unresponsive or so slow that it might as well be (only tested with any cuda app that has any graphics … only ones last long enough)

EDIT3: Apparently there is a problem if something renders to fast so if you run opengl programs that are going INSANELY fast the comp freezes SO do this