/usr/share/doc/jetson-gpio-common/samples$ sudo ./run_sample.sh simple_out.py

Hello,

I’m using R32 revision 4.3.

cat /etc/nv_tegra_release
R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun 26 04:38:25 UTC 2020

I have tried /usr/share/doc/jetson-gpio-common/samples$ sudo ./run_sample.sh simple_out.py.

It doesn’t work.

./run_sample.sh simple_out.py
./run_sample.sh: line 25: cd: /usr/share/doc/jetson-gpio-common/lib/python: No such file or directory
./run_sample.sh: line 58: /usr/share/doc/jetson-gpio-common/samples/simple_out.py: Permission denied
./run_sample.sh: line 58: exec: /usr/share/doc/jetson-gpio-common/samples/simple_out.py: cannot execute: Permission denied

======== https://www.jetsonhacks.com/2019/06/07/jetson-nano-gpio/ ==========
We can run the sample for simple output to control our LED:

$ cd /usr/share/doc/jetson-gpio-common/samples$ sudo ./run_sample.sh simple_out.py

========================================================================

How can I run this example?

Thank you.

Hello,

nx xavier is using R32 revision 4.4

The run_sample.sh script does not exist in the /usr/share/doc/jetson-gpio-common/samples path.

Was it deleted as the jetpack version went up?

Thank you.

hello neuezeal,

please clone Jetson GPIO python library for usage.
you may also check readme file for the steps to run sample scripts.
thanks

1 Like