UX around material slots

I haven’t found a good video or help page documenting this yet, but if I’ve understood things correctly… meshes with only one material appear as meshes with one material in the Stage tree… but meshes with more than one materials have GeomSubset children for each material… yet replacing the material on those doesn’t show up in the viewport… clicking on such an object in the viewport (which highlights the mesh) and choosing assign material does also seemingly nothing… however, selecing the material in the Stage Materials list and perform “select bound object” does allow me to replace the material. What did I miss?

(Also, a bit confusing… this is the white plastic material I’ve used from the Nvidia Materials panel where it’s white… yet after being assigned the th)umbnail in the Properties are always yellow for some reason.

EDIT: I just noticed that dragging a new material from the Materials panel on top of the thumbnail of the child does work… and after I tried that, changing materials in the drop menu also works… so… not sure why it wasn’t reflected in the viewport the first time I tried it.

However, one thing I still cannot figure out is how to revert a material re-assignment here. There’s no blue box to indicate that something has changed compared to the original layer either.

1 Like

Hi EDRobert,
If I read this correct, its now working well, except for your question about reverting back to original materials. There is no specific command to revit back to the raw original imported material. I can make a feature request for that. If you assign a material and change your mind, of course you can use the undo button. Also all the materials for the whole scene, both used and unused are still stored in your Looks folder, or somewhere in the stage tree. They will not be removed unless you speciifically do so to delete them. So just find the original and drag it back.

Maybe I missed some UX around how to work with layers, but is there really no option to remove a change made in a Layer? Also, I’m having difficulties seeing exactly what changes were made in a Layer because by default it seems that everything shows up in the Layer tree? (The Layer tree, btw, also has confusing UX is that it seemingly highlights allowing drag and drops from, for example the Materials panel when it doesn’t seem to accept any drag and drop operations.) I might have gotten a few things wrong, but it’s not exactly intuitive. Tomorrow will be spent looking at various videos on Layers that I found.

But yes, getting a blue box to revert changes for material assignments would be really nice and consistent with the UX for other changes in the Properties panel!

I just answered your other post about materials and layers. I did not realize you were assigning materials via a new layer. In that case, things are very very simple. You just delete the new materials layer and the model will be reverted back to original import. One of the advantages of that workflow.

Right, but what’s the process around reviewing what changes was made in a layer?

When you expand the layer down, you can see all of the “deltas” in there for everything you did. You can delete them as needed.

1 Like

This is a separate topic now, I guess and I will review any tutorials around this I can find in the upcoming days, but when I expand the new layer where I did my material assignments, it appears to me that everything is in there, not just the things I changed…

For example, in this above screenshot, there has been no change to the DIN_916_M8_X_12_Socket object that I’m aware of. Is there a “deltas” filter I can enable to just see anything that’s changed?

The delta symbol will appear only next to the changes.

There’s apparently a choice when you create a new layer, to transfer all layer contents. A new user would have no reason to say no, so I didn’t. The result is apparently what you see above with no easy way to find deltas.

If the “yes” option is the advanced use case, the UX around this could be better.