V-sync in Windows 8 DWM

I have a problem with v-sync in Windows 8 desktop. Windows 8 has DWM always on, and DWM forces v-sync enabled. This causes noticeable lag in the whole system, not only in windowed games. Making selection rectangle on desktop or scrolling web page produces annoying lag.
It is impossible to disable DWM or v-sync, even forcing it off in NVidia control panel doesn’t work.

Do you have any ideas how to solve that problem? Some way of forcing v-sync off in the drivers would be an answer. Or making Microsoft give the possibility to disable it in DWM.

Yeah, it’s bad. Please do something about this NVIDIA and/or Microsoft. I’m really trying to move off of Windows XP, but shit like this makes it difficult.